postgresql: move systemd service file to /usr/lib
authorMike Williams <mike@mikebwilliams.com>
Fri, 20 Mar 2015 19:14:02 +0000 (15:14 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Mar 2015 19:39:26 +0000 (20:39 +0100)
Signed-off-by: Mike Williams <mike@mikebwilliams.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/postgresql/postgresql.mk

index 7bb16787e91876731187cb5a0da9ab98092e8755..bc382ce50a453cb73aa7bbb81136d26f992b3b4f 100644 (file)
@@ -85,9 +85,9 @@ endef
 
 define POSTGRESQL_INSTALL_INIT_SYSTEMD
        $(INSTALL) -D -m 644 package/postgresql/postgresql.service \
-               $(TARGET_DIR)/etc/systemd/system/postgresql.service
+               $(TARGET_DIR)/usr/lib/systemd/system/postgresql.service
        mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
-       ln -fs ../postgresql.service \
+       ln -fs ../../../../usr/lib/systemd/system/postgresql.service \
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/postgresql.service
 endef