docs/manual: copying the manual sources is a common action
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 3 Oct 2014 17:01:39 +0000 (19:01 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 12 Oct 2014 05:46:26 +0000 (07:46 +0200)
Move the creation of $(BUILD_DIR)/manual and the rsyncing of the
sources into GENDOC.

This is is needed so that GENDOC can be easily used to generate another
document, without requiring that document to duplicate the copying rules.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Samuel Martin <s.martin49@gmail.com>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Reviewed-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Reviewed-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
docs/manual/manual.mk

index 69113e350a7324c74342a7b1ab7eb953ccc57e2c..dd6f0ea01504d14c40b193624b068475a68df6e5 100644 (file)
@@ -1,10 +1,3 @@
-$(BUILD_DIR)/docs/$(pkgname):
-       $(Q)mkdir -p $@
-
-manual-rsync: $(BUILD_DIR)/docs/$(pkgname)
-       $(Q)$(call MESSAGE,"Preparing the manual sources...")
-       $(Q)rsync -a docs/$(pkgname)/ $(BUILD_DIR)/docs/$(pkgname)
-
 # Packages included in BR2_EXTERNAL are not part of buildroot, so they
 # should not be included in the manual.
 manual-update-lists: manual-check-dependencies-lists $(BUILD_DIR)/docs/$(pkgname)
@@ -127,6 +120,13 @@ endef
 # The variable <DOCUMENT_NAME>_SOURCES defines the dependencies.
 ################################################################################
 define GENDOC
+$$(BUILD_DIR)/docs/$(pkgname):
+       $$(Q)mkdir -p $$@
+
+$(pkgname)-rsync: $$(BUILD_DIR)/docs/$(pkgname)
+       $$(Q)$$(call MESSAGE,"Preparing the $(pkgname) sources...")
+       $$(Q)rsync -a docs/$(pkgname)/ $$^
+
 $(call GENDOC_INNER,$(pkgname),xhtml,html,html,HTML,\
        --xsltproc-opts "--stringparam toc.section.depth 1")
 $(call GENDOC_INNER,$(pkgname),chunked,split-html,chunked,split HTML,\