mpd: bump to version 0.18.7
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 13 Jan 2014 22:17:18 +0000 (19:17 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 13 Jan 2014 22:22:17 +0000 (23:22 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpd/Config.in
package/mpd/S95mpd
package/mpd/mpd.mk

index 62bdfa7c526b32773ade3c5f1280ceb28a8d0493..5a03a62a35d76bfe47ea41cb8a3b665d6d92a812 100644 (file)
@@ -4,6 +4,8 @@ menuconfig BR2_PACKAGE_MPD
        depends on BR2_USE_WCHAR # libglib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
        depends on BR2_USE_MMU # libglib2
+       depends on !(BR2_avr32 || BR2_sparc) # gcc too old
+       depends on !BR2_UCLIBC_VERSION_0_9_32 # lacks signalfd
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        select BR2_PACKAGE_MPD_TREMOR if !(BR2_PACKAGE_MPD_MAD || BR2_PACKAGE_MPD_MPG123 || BR2_PACKAGE_MPD_VORBIS || BR2_PACKAGE_MPD_WAVPACK || BR2_PACKAGE_MPD_FLAC || BR2_PACKAGE_MPD_MUSEPACK || BR2_PACKAGE_MPD_FFMPEG)
@@ -142,6 +144,19 @@ config BR2_PACKAGE_MPD_MUSEPACK
          Enable musepack input support.
          Select this if you want to play back MPC files.
 
+config BR2_PACKAGE_MPD_OPUS
+       bool "opus"
+       select BR2_PACKAGE_OPUS
+       help
+         Enable opus input support.
+         Select this if you want to play back OPUS encoded files.
+
+config BR2_PACKAGE_MPD_SOUNDCLOUD
+       bool "soundcloud"
+       select BR2_PACKAGE_YAJL
+       help
+         Enable soundcloud.com playlist support.
+
 config BR2_PACKAGE_MPD_SQLITE
        bool "sqlite"
        select BR2_PACKAGE_SQLITE
index a4f1271cea83b31a30737d0e89e4ee8db95c2bb7..f25135d38b3910aa8c03eb74d16ba7a644b04e2e 100644 (file)
@@ -1,15 +1,19 @@
 #!/bin/sh
 
+# Sanity checks
+test -f /usr/bin/mpd || exit 0
+test -f /etc/mpd.conf || exit 0
+
 start() {
        echo -n "Starting mpd: "
-       start-stop-daemon --start --quiet --background --exec /usr/bin/mpd
-       echo "OK"
+       start-stop-daemon --start --quiet --background --exec /usr/bin/mpd \
+               && echo "OK" || echo "FAIL"
 }
 
 stop() {
        echo -n "Stopping mpd: "
-       start-stop-daemon --stop --quiet --pidfile /var/run/mpd.pid
-       echo "OK"
+       start-stop-daemon --stop --quiet --pidfile /var/run/mpd.pid \
+               && echo "OK" || echo "FAIL"
 }
 
 case "$1" in
index 4367cae0722e7d02a1688e0826754d12ac8e86c3..4a7926cd6143784d12f7070c611f9fa72819402d 100644 (file)
@@ -4,12 +4,12 @@
 #
 ################################################################################
 
-MPD_VERSION_MAJOR = 0.17
-MPD_VERSION = $(MPD_VERSION_MAJOR).6
+MPD_VERSION_MAJOR = 0.18
+MPD_VERSION = $(MPD_VERSION_MAJOR).7
 MPD_SOURCE = mpd-$(MPD_VERSION).tar.xz
 MPD_SITE = http://www.musicpd.org/download/mpd/$(MPD_VERSION_MAJOR)
 MPD_DEPENDENCIES = host-pkgconf libglib2
-MPD_LICENSE = GPLv2
+MPD_LICENSE = GPLv2+
 MPD_LICENSE_FILES = COPYING
 
 # Some options need an explicit --disable or --enable
@@ -82,6 +82,12 @@ else
 MPD_CONF_OPT += --disable-sndfile
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_OPUS),y)
+MPD_DEPENDENCIES += opus
+else
+MPD_CONF_OPT += --disable-opus
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_VORBIS),y)
 MPD_DEPENDENCIES += libvorbis
 else
@@ -100,6 +106,12 @@ else
 MPD_CONF_OPT += --disable-mpc
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_SOUNDCLOUD),y)
+MPD_DEPENDENCIES += yajl
+else
+MPD_CONF_OPT += --disable-soundcloud
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_SQLITE),y)
 MPD_DEPENDENCIES += sqlite
 else