linux: add shorter shortcuts
authorMike Frysinger <vapier@gentoo.org>
Thu, 18 Nov 2010 11:31:46 +0000 (06:31 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 11 Dec 2010 01:01:10 +0000 (02:01 +0100)
We only have one Linux kernel package, and "linux26-" is an anachronism
in today's world.  So add useful "linux-%" shortcuts to the "linux26-%".

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
docs/README
docs/buildroot.html
linux/linux.mk

index c330a606bb5f07759bc193799b5f7ff98fa312d0..e756329b59e36c6ac1a6c4bb3ee5fdef4adf2b88 100644 (file)
@@ -53,7 +53,7 @@ $ make HOSTCC=gcc-4.3.orig HOSTCXX=gcc-4.3-mine
 
 Depending on your configuration, there are some targets you can use to
 use menuconfig of certain packages. This includes:
-$ make HOSTCC=gcc-4.3 linux26-menuconfig
+$ make HOSTCC=gcc-4.3 linux-menuconfig
 $ make HOSTCC=gcc-4.3 uclibc-menuconfig
 $ make HOSTCC=gcc-4.3 busybox-menuconfig
 
index b6cf578bdc3756d18421f8da18ad0d45b30a0aee..8293c8fec3e02c5ab3e45e782662f5457cf9bb7e 100644 (file)
 
     <p>The Linux kernel configuration can be customized just like
     <a href="#custom_busybox">BusyBox</a> and
-    <a href="#custom_uclibc">uClibc</a> using <code>make linux26-menuconfig
+    <a href="#custom_uclibc">uClibc</a> using <code>make linux-menuconfig
     </code>. Make sure you have enabled the kernel build in <code>make
     menuconfig</code> first. Once done, run <code>make</code> to (re)build
     everything.</p>
index ab90c03e48d52b8dacdc4c44b63a1da78ba4e6eb..5f89b7dd33e18bf25bbbfd39df1ffcd2ef131ca2 100644 (file)
@@ -179,3 +179,6 @@ endif
 endif
 
 endif
+
+linux-%:
+       $(MAKE) $(subst linux-,linux26-,$@)