package/bullet: new package
authorRomain Naour <romain.naour@openwide.fr>
Fri, 24 Apr 2015 19:46:11 +0000 (21:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Apr 2015 09:09:41 +0000 (11:09 +0200)
[Thomas:
  - move package to 'Libraries -> Graphics'
  - wrap the Config.in help text
  - change license from "Zlib" to "zlib license" to match what the
    zlib package is doing.]

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/bullet/Config.in [new file with mode: 0644]
package/bullet/bullet.mk [new file with mode: 0644]

index afa145eefefd74b4152e157f3d519884ee5bef58..7e25109710d31083d0431362cbf576a0563d8743 100644 (file)
@@ -750,6 +750,7 @@ endmenu
 
 menu "Graphics"
        source "package/atk/Config.in"
+       source "package/bullet/Config.in"
        source "package/cairo/Config.in"
        source "package/exiv2/Config.in"
        source "package/fltk/Config.in"
diff --git a/package/bullet/Config.in b/package/bullet/Config.in
new file mode 100644 (file)
index 0000000..fc285ab
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_BULLET
+       bool "bullet"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         Bullet is a Collision Detection and Rigid Body Dynamics
+         Library.
+
+         http://bulletphysics.org
+
+comment "bullet needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/bullet/bullet.mk b/package/bullet/bullet.mk
new file mode 100644 (file)
index 0000000..3ec97b4
--- /dev/null
@@ -0,0 +1,18 @@
+################################################################################
+#
+# bullet
+#
+################################################################################
+
+# This is the git id of the 2.82 release.
+BULLET_VERSION = 19f999ac087e68ffc2551ffb73e35e60271a0d27
+BULLET_SITE = $(call github,bulletphysics,bullet3,$(BULLET_VERSION))
+BULLET_INSTALL_STAGING = YES
+BULLET_LICENSE = zlib license
+BULLET_LICENSE_FILES = BulletLicense.txt COPYING
+
+# Disable GLUT support since there is no freeglut or OpenGLUT package and we
+# don't build the demos apps.
+BULLET_CONF_OPTS = -DUSE_GLUT=OFF -DBUILD_DEMOS=OFF
+
+$(eval $(cmake-package))