Config.in: add BR2_HOST_GCC_AT_LEAST_9
authorRomain Naour <romain.naour@smile.fr>
Tue, 25 Feb 2020 21:22:13 +0000 (22:22 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 25 Feb 2020 22:21:50 +0000 (23:21 +0100)
Fedora 30 switched to GCC 9.x. [1]

[1] https://fedoraproject.org/wiki/Changes/GCC9

Signed-off-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in
Makefile

index 2913d39ec8a9876d114112f86ae93336ae158cdc..90403037e61ea4117b4d7dd6de027612ea948832 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -50,6 +50,11 @@ config BR2_HOST_GCC_AT_LEAST_8
        default y if BR2_HOST_GCC_VERSION = "8"
        select BR2_HOST_GCC_AT_LEAST_7
 
+config BR2_HOST_GCC_AT_LEAST_9
+       bool
+       default y if BR2_HOST_GCC_VERSION = "9"
+       select BR2_HOST_GCC_AT_LEAST_8
+
 # When adding new entries above, be sure to update
 # the HOSTCC_MAX_VERSION variable in the Makefile.
 
index 9e38e2cae3d4b1f949818ac4aac39d8b788cea0c..40e71ffbf49d36ef9d4129888f5c7bb862eacd5c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -340,7 +340,7 @@ export HOSTARCH := $(shell LC_ALL=C $(HOSTCC_NOCCACHE) -v 2>&1 | \
 
 # When adding a new host gcc version in Config.in,
 # update the HOSTCC_MAX_VERSION variable:
-HOSTCC_MAX_VERSION := 8
+HOSTCC_MAX_VERSION := 9
 
 HOSTCC_VERSION := $(shell V=$$($(HOSTCC_NOCCACHE) --version | \
        sed -n -r 's/^.* ([0-9]*)\.([0-9]*)\.([0-9]*)[ ]*.*/\1 \2/p'); \