madplay: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:58:12 +0000 (22:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:28:45 +0000 (01:28 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/madplay/Config.in
package/madplay/madplay.mk

index d83fac6d1f30a19582a61be23cc669429207da92..3baeaa06314a102aa612b0bbdf45129be2c11c11 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_MADPLAY
        bool "madplay"
        select BR2_PACKAGE_LIBMAD
        select BR2_PACKAGE_LIBID3TAG
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          Command-line front-end to libmad, a high-quality MPEG audio decoder.
          It currently supports MPEG-1 and the MPEG-2 extension to lower
index 4ae95abdd44a0138bf23beb445cac962766f5822..e72e2f81800968b989c50b6f9c020525cea127c8 100644 (file)
@@ -9,7 +9,7 @@ MADPLAY_SITE = http://downloads.sourceforge.net/project/mad/madplay/$(MADPLAY_VE
 MADPLAY_LICENSE = GPL-2.0+
 MADPLAY_LICENSE_FILES = COPYING COPYRIGHT
 MADPLAY_LIBTOOL_PATCH = NO
-MADPLAY_DEPENDENCIES = libmad libid3tag $(if $(BR2_PACKAGE_GETTEXT),gettext)
+MADPLAY_DEPENDENCIES = libmad libid3tag $(TARGET_NLS_DEPENDENCIES)
 
 # Check if ALSA is built, then we should configure after alsa-lib so
 # ./configure can find alsa-lib.