package/libjpeg: switch to package-defined providers
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 20 Dec 2013 22:27:58 +0000 (23:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 25 Dec 2013 17:21:44 +0000 (18:21 +0100)
For the underlying reasons, see previous patch, titled:
    package/opengl/libegl: switch to package-defined providers

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/jpeg/Config.in
package/jpeg/jpeg.mk

index 9508faf24dd70196c8f21cfd17f8860adae0b2dd..b7cdfeb79a18c6a33d558728e9978590478b8b86 100644 (file)
@@ -30,4 +30,9 @@ config BR2_PACKAGE_JPEG_TURBO
 
 endchoice
 
+config BR2_PACKAGE_PROVIDES_JPEG
+       string
+       default "libjpeg"    if BR2_PACKAGE_LIBJPEG
+       default "jpeg-turbo" if BR2_PACKAGE_JPEG_TURBO
+
 endif
index eaa23944c1c26f3e58441e3342bff9cce83b5d31..3695bc818dcc9111faf8ec49be2a002b53e5897a 100644 (file)
@@ -5,14 +5,7 @@
 ################################################################################
 
 JPEG_SOURCE =
-
-ifeq ($(BR2_PACKAGE_JPEG_TURBO),y)
-JPEG_DEPENDENCIES += jpeg-turbo
-endif
-
-ifeq ($(BR2_PACKAGE_LIBJPEG),y)
-JPEG_DEPENDENCIES += libjpeg
-endif
+JPEG_DEPENDENCIES = $(call qstrip,$(BR2_PACKAGE_PROVIDES_JPEG))
 
 ifeq ($(JPEG_DEPENDENCIES),)
 define JPEG_CONFIGURE_CMDS