package/hans: fix build failures with high 'make -j' values
authorRomain Naour <romain.naour@gmail.com>
Wed, 31 May 2017 19:12:49 +0000 (21:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 31 May 2017 19:32:24 +0000 (21:32 +0200)
The top-level doesn't handle correctly the build dependencies
between .o files.

Since hans doesn't take too many time to build, just use MAKE1.

Fixes:
http://autobuild.buildroot.net/results/d14/d142f4a439d4d5fcc89865abde3e593c45ad5d96
http://autobuild.buildroot.net/results/28e/28ed230e40cc154db9274f9765085cd7f0eee85a
http://autobuild.buildroot.net/results/900/9008c3be3bcf46f0fc21a34f48e3cf9da1397d9a

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/hans/hans.mk

index 2e1e0024e2127ac5760e43a380cd300ae1687e58..505858123f1b26c42870b9687ef9fb603745458c 100644 (file)
@@ -10,7 +10,7 @@ HANS_LICENSE = GPL-3.0+
 HANS_LICENSE_FILES = LICENSE
 
 define HANS_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) GCC="$(TARGET_CC)" GPP="$(TARGET_CXX)" -C $(@D)
+       $(TARGET_MAKE_ENV) $(MAKE1) GCC="$(TARGET_CC)" GPP="$(TARGET_CXX)" -C $(@D)
 endef
 
 define HANS_INSTALL_TARGET_CMDS