Makefile: add /etc/bash_completion.d to non-bash purge
authorDanomi Manchego <danomimanchego123@gmail.com>
Tue, 14 Jul 2020 02:24:59 +0000 (22:24 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 14 Jul 2020 08:11:18 +0000 (10:11 +0200)
Currently, we delete /usr/share/bash-completion when bash is not enabled.
We need to delete /etc/bash_completion.d too. For example, the jo package
installs files there:

/etc/bash_completion.d/jo.bash

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Makefile

index 8355de5ffa8cc6d91c87551b9594165f7de3124f..7bd8ada488a58ebe56d0dd4677503e4ca9c78228 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -756,6 +756,7 @@ ifneq ($(BR2_PACKAGE_GDB),y)
 endif
 ifneq ($(BR2_PACKAGE_BASH),y)
        rm -rf $(TARGET_DIR)/usr/share/bash-completion
+       rm -rf $(TARGET_DIR)/etc/bash_completion.d
 endif
 ifneq ($(BR2_PACKAGE_ZSH),y)
        rm -rf $(TARGET_DIR)/usr/share/zsh