projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
19d1ca2
)
package/libvpx: vp9 encoder needs c++
author
Bernd Kuhls
<bernd.kuhls@t-online.de>
Wed, 23 Sep 2020 18:08:30 +0000
(20:08 +0200)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Wed, 23 Sep 2020 18:46:07 +0000
(20:46 +0200)
Encoding rate control interface for v9 is implemented in c++:
https://github.com/webmproject/libvpx/commit/
745979bc2913b4f26847084699d9fddd68b60410
#diff-58f26933c120328b31831a743eec5ba3R534
Disable vp9 encoding when toolchain lacks c++.
Fixes:
http://autobuild.buildroot.net/results/983/
9836215fe22f260483f9153fb5447892801a14a9
/
http://autobuild.buildroot.net/results/88a/
88aa80ee006ba2dcc40c15be3af73c756cb62974
/
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libvpx/libvpx.mk
patch
|
blob
|
history
diff --git
a/package/libvpx/libvpx.mk
b/package/libvpx/libvpx.mk
index c7245885d9563c1152d1a7fd912693baf392e2a9..26d211cf86e75bb7c0b5ff28c56b5c8ad0bc5c37 100644
(file)
--- a/
package/libvpx/libvpx.mk
+++ b/
package/libvpx/libvpx.mk
@@
-20,6
+20,13
@@
LIBVPX_CONF_OPTS = \
--disable-docs \
--disable-unit-tests
+# vp9/ratectrl_rtc.cc
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+LIBVPX_CONF_OPTS += --enable-vp9-encoder
+else
+LIBVPX_CONF_OPTS += --disable-vp9-encoder
+endif
+
# This is not a true autotools package. It is based on the ffmpeg build system
define LIBVPX_CONFIGURE_CMDS
(cd $(LIBVPX_SRCDIR) && rm -rf config.cache && \