gob2: update dependency on flex
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2010 12:21:39 +0000 (13:21 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Feb 2010 19:34:33 +0000 (20:34 +0100)
gob2 for the target needs both flex on the host (for running the flex
program at compile time) and flex on the target (so that it can link
against libfl.a).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gob2/Config.in
package/gob2/gob2.mk

index 314a1da7e26a1fc840465747102f9cc7e3f198b1..2545bafa62cb5c3b654fdd9c91de8e5171b77ca7 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_GOB2
        bool "gob2"
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_FLEX
+       select BR2_PACKAGE_FLEX_LIBFL
        select BR2_PACKAGE_BISON
        help
          GOB (GTK+ Object Builder) is a preprocessor which simplifies
index cdf7961b1374107566d87836deba7ac3f721712f..5d50ed6cb6ba4a9316fabe98ad4d16b5e5923f03 100644 (file)
@@ -7,7 +7,7 @@ GOB2_VERSION = 2.0.15
 GOB2_SOURCE = gob2-$(GOB2_VERSION).tar.gz
 GOB2_SITE = http://ftp.5z.com/pub/gob/
 
-GOB2_DEPENDENCIES = libglib2 flex bison host-pkg-config
+GOB2_DEPENDENCIES = libglib2 flex bison host-pkg-config host-flex
 
 HOST_GOB2_DEPENDENCIES = host-libglib2