msgpack: fix build without threads support
authorBaruch Siach <baruch@tkos.co.il>
Tue, 17 Oct 2017 14:42:12 +0000 (17:42 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 Oct 2017 19:58:35 +0000 (21:58 +0200)
Some example code depends on pthreads, and we generally don't build
examples in Buildroot, so disable their build.

Fixes:
http://autobuild.buildroot.net/results/f5d/f5d493dbe65cbe58d0924176efbd12e4a078f3ee/
http://autobuild.buildroot.net/results/813/81387649d9dbdfe4ccba9c7d0885aa8bd5239938/
http://autobuild.buildroot.net/results/9d4/9d486fca93136bb9dbf22c9101186d9d1fc0eb66/

Cc: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
[Thomas: completely disable examples.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/msgpack/msgpack.mk

index f6f3ab0c83f9c4473670bc5639bac3413cebd1db..7b92f3f981d07ce4fe5a53f46d87abd611f9edf6 100644 (file)
@@ -9,5 +9,6 @@ MSGPACK_SITE = $(call github,msgpack,msgpack-c,cpp-$(MSGPACK_VERSION))
 MSGPACK_LICENSE = BSL-1.0
 MSGPACK_LICENSE_FILES = COPYING LICENSE_1_0.txt
 MSGPACK_INSTALL_STAGING = YES
+MSGPACK_CONF_OPTS = -DMSGPACK_BUILD_EXAMPLES=OFF
 
 $(eval $(cmake-package))