package/python: re-enable hashlib
authorTitouan Christophe <titouan.christophe@railnova.eu>
Mon, 3 Feb 2020 11:18:37 +0000 (12:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 3 Feb 2020 11:29:36 +0000 (12:29 +0100)
In commit e5cfb319f9493d677f059ca72b80f7fa22fc9f0f,
the committer did add the flag `--disable-hashlib` to python,
even though this was not part of the original patch
(https://patchwork.ozlabs.org/patch/1231905/).

This unexpected modification break the builds of waf-based
packages, such as jack2, mpv or aubio. This commit therefore

Fixes: http://autobuild.buildroot.net/results/2b3/2b377bcfda6e7ae4d6bb894664e3a4cb13a70b6d/
Fixes: http://autobuild.buildroot.net/results/cd5/cd5da8cb3da8479ebee60d011ce0c5dc0e59aab7/
Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python/python.mk

index 9e3c32687c136506a1552b5708ebe3719f60045e..41a981e3d342fc0e4059deee2ed676135a994d4b 100644 (file)
@@ -60,7 +60,7 @@ HOST_PYTHON_DEPENDENCIES = host-expat host-zlib
 ifeq ($(BR2_PACKAGE_HOST_PYTHON_SSL),y)
 HOST_PYTHON_DEPENDENCIES += host-openssl
 else
-HOST_PYTHON_CONF_OPTS += --disable-ssl --disable-hashlib
+HOST_PYTHON_CONF_OPTS += --disable-ssl
 endif
 
 PYTHON_INSTALL_STAGING = YES