package{protobuf,python-protobuf}: bump to v3.2.0
authorMario J. Rugiero <mrugiero@gmail.com>
Fri, 21 Apr 2017 16:06:37 +0000 (13:06 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Apr 2017 13:23:45 +0000 (15:23 +0200)
Both packages are coupled, so both are bumped and build-tested.

The atomics' support patch is no longer needed, and neither is the
autoreconf option, and SPARC64 is no longer broken.

To make sure of this, one config of each of the following archs was
tested (base defconfig in parens):

 - PowerPC (qemu_ppc_g3beige_defconfig)
 - SPARC (qemu_sparc_ss10_defconfig)
 - SPARC64 (qemu_sparc64_sun4u_defconfig)

Signed-off-by: Mario J. Rugiero <mrugiero@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/protobuf/0001-configure.ac-check-if-libatomic-is-needed.patch [deleted file]
package/protobuf/Config.in
package/protobuf/protobuf.hash
package/protobuf/protobuf.mk
package/python-protobuf/python-protobuf.hash [changed from symlink to file mode: 0644]
package/python-protobuf/python-protobuf.mk

diff --git a/package/protobuf/0001-configure.ac-check-if-libatomic-is-needed.patch b/package/protobuf/0001-configure.ac-check-if-libatomic-is-needed.patch
deleted file mode 100644 (file)
index fffdf49..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From f020fe05a20dfcd16cd7df833dcf3cdeef770538 Mon Sep 17 00:00:00 2001
-From: Carlos Santos <casantos@datacom.ind.br>
-Date: Thu, 11 Feb 2016 10:58:35 -0200
-Subject: [PATCH 2/2] configure.ac: check if libatomic is needed
-
-Compilation of protobuf for PowerPC and SPARC may fail due to missing
-references to __atomic_fetch_add_4 and __atomic_compare_exchange_4.
-
-The __atomic_*() intrinsics for all sizes are provided by libatomic when
-gcc is >= 4.8. This can be achieved by adding this to configure.ac:
-
-    AC_SEARCH_LIBS([__atomic_fetch_add_4], [atomic])
-
-Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
----
- configure.ac | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index c07067c..88d4a0d 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -160,6 +160,8 @@ AM_CONDITIONAL([HAVE_PTHREAD], [test "x$acx_pthread_ok" = "xyes"])
- # We still keep this for improving pbconfig.h for unsupported platforms.
- AC_CXX_STL_HASH
-+AC_SEARCH_LIBS([__atomic_load_4], [atomic])
-+
- case "$target_os" in
-   mingw* | cygwin* | win*)
-     ;;
--- 
-2.5.0
-
index bece56c29e9d19d4d43ebef9a6572c98eb101a88..03d118cfc1200134578b3425004941e8ee7225b1 100644 (file)
 # *could* technically build with gcc 4.7. This is probably not a big deal,
 # and we can live with requiring gcc 4.8 on PowerPC to build protobuf.
 #
-# The SPARC64 build fails due to a missing definition of Atomic64. This
-# has been fixed on the master branch but the build still breaks due to
-# undefined references to internal NoBarrier_Atomic*() functions.
-#
 # host-protobuf only builds on certain architectures
 config BR2_PACKAGE_PROTOBUF_ARCH_SUPPORTS
        bool
@@ -24,8 +20,8 @@ config BR2_PACKAGE_PROTOBUF_ARCH_SUPPORTS
        default y if BR2_i386
        default y if BR2_mipsel
        default y if BR2_x86_64
+       default y if BR2_sparc64
        default y if BR2_TOOLCHAIN_HAS_ATOMIC
-       depends on !BR2_sparc64 # missing definition of Atomic64
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
        depends on BR2_USE_MMU # fork()
 
index b681650a132062eb9f297dedaf0698bf26b7abc1..9ec6bc759d8f185f0f04e3d914d4d61ad066f0e3 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 f5b3563f118f1d3d6e001705fa7082e8fc3bda50038ac3dff787650795734146 protobuf-v3.0.0.tar.gz
+sha256 51d773e4297238b282eaa4c1dd317099675b12eef2b414732b851c00459225c6 protobuf-cpp-3.2.0.tar.gz
index 72930c1fef321e01654df8e79157b84de4ca3aa2..a3e96d4f898c79eb767aef651240dd778ca7ce37 100644 (file)
@@ -7,12 +7,11 @@
 # When bumping this package, make sure to also verify if the
 # python-protobuf package still works, as they share the same
 # version/site variables.
-PROTOBUF_VERSION = v3.0.0
-PROTOBUF_SITE = $(call github,google,protobuf,$(PROTOBUF_VERSION))
+PROTOBUF_VERSION = 3.2.0
+PROTOBUF_SOURCE = protobuf-cpp-$(PROTOBUF_VERSION).tar.gz
+PROTOBUF_SITE = https://github.com/google/protobuf/releases/download/v$(PROTOBUF_VERSION)
 PROTOBUF_LICENSE = BSD-3-Clause
 PROTOBUF_LICENSE_FILES = LICENSE
-# no configure script
-PROTOBUF_AUTORECONF = YES
 
 # N.B. Need to use host protoc during cross compilation.
 PROTOBUF_DEPENDENCIES = host-protobuf
deleted file mode 120000 (symlink)
index 57a40ce5bd28bdbf202bfcae95d2d7e2e4204f69..0000000000000000000000000000000000000000
+++ /dev/null
@@ -1 +0,0 @@
-../protobuf/protobuf.hash
\ No newline at end of file
new file mode 100644 (file)
index 0000000000000000000000000000000000000000..c87403f2475353e9503e48131e6483074b47045f
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 c574e2b2178ffe66599274e8cfa11ecf83799a7992be30f0b68fb33ea0a0f1af protobuf-python-3.2.0.tar.gz
index 5a6488918a6fedb6526835da985dcb1f652cdbf9..b91ba49339d40f0c86c2a602743d59bfc9b023c7 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 PYTHON_PROTOBUF_VERSION = $(PROTOBUF_VERSION)
-PYTHON_PROTOBUF_SOURCE = $(PROTOBUF_SOURCE)
+PYTHON_PROTOBUF_SOURCE = protobuf-python-$(PYTHON_PROTOBUF_VERSION).tar.gz
 PYTHON_PROTOBUF_SITE = $(PROTOBUF_SITE)
 PYTHON_PROTOBUF_LICENSE = BSD-3-Clause
 PYTHON_PROTOBUF_LICENSE_FILES = LICENSE