gettext: remove support for gettext-tools on target
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 Jun 2014 20:23:30 +0000 (22:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 9 Jun 2014 13:43:09 +0000 (15:43 +0200)
This commit removes the BR2_PACKAGE_GETTEXT_TOOLS option, which could
be used to install gettext tools on the target. This is not needed,
because Buildroot is not designed to provide a full development
environment on the target, and gettext translation files should be
processed on the build machine, using the host gettext tools.

Remove this option will allow to optimize the build time of gettext on
the target, by only building the gettext runtime libraries.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tested-by: Andrew Ruder <andrew.ruder@elecsyscorp.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Config.in.legacy
package/gettext/Config.in
package/gettext/gettext.mk

index 9e8be3d14edf10645645c2b649eee65031a17c62..c6bb2fe3427f9d9be052ab7cb063c3135b379418 100644 (file)
@@ -101,6 +101,16 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2014.08"
 
+config BR2_PACKAGE_GETTEXT_TOOLS
+       bool "support for gettext-tools on target has been removed"
+       select BR2_LEGACY
+       help
+         The option to install the gettext utilities on the target
+         has been removed. This is not necessary as Buildroot is not
+         designed to provide a full development environment on the
+         target. gettext tools should be used on the build machine
+         instead.
+
 config BR2_PACKAGE_PROCPS
        bool "procps has been replaced by procps-ng"
        select BR2_PACKAGE_PROCPS_NG
index d33dd3a05fa3720f4728faa8682f6f21ca1ca2c2..158b14ebed699fd74c2a82d81d85e7dd8bfafd79 100644 (file)
@@ -13,20 +13,6 @@ config BR2_PACKAGE_GETTEXT
 
          http://www.gnu.org/software/gettext/
 
-if BR2_PACKAGE_GETTEXT
-
-config BR2_PACKAGE_GETTEXT_TOOLS
-       bool "Install gettext tools"
-       depends on BR2_USE_MMU # fork()
-       depends on BR2_LARGEFILE
-       select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
-       help
-         This option allows to install the complete gettext suite in
-         the target filesystem. This is typically not useful for
-         correct operation of programs.
-
-endif
-
 comment "gettext needs a toolchain w/ wchar"
        depends on BR2_NEEDS_GETTEXT
        depends on !BR2_USE_WCHAR
index b5efa766d3d54fd0e5abc0e4b71eeee05f0ed7ab..52a72db716805378f241d8e7949dd7a7555eb6fe 100644 (file)
@@ -46,16 +46,12 @@ ifeq ($(BR2_ENABLE_LOCALE),)
 GETTEXT_CONF_OPT += --enable-nls
 endif
 
-# When the gettext tools are not enabled in the configuration, we only
-# install libintl to the target.
-ifeq ($(BR2_PACKAGE_GETTEXT_TOOLS),)
 # When static libs are preferred the .so files aren't created
 ifeq ($(BR2_PREFER_STATIC_LIB),)
 define GETTEXT_INSTALL_TARGET_CMDS
        cp -dpf $(STAGING_DIR)/usr/lib/libintl*.so* $(TARGET_DIR)/usr/lib/
 endef
 endif
-endif # GETTEXT_TOOLS = n
 
 # Disable interactive confirmation in host gettextize for package fixups
 define HOST_GETTEXT_GETTEXTIZE_CONFIRMATION