package/netsurf: disallow on archs requiring ABI specific CFLAGS
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 31 May 2019 21:40:52 +0000 (23:40 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 1 Jun 2019 08:16:25 +0000 (10:16 +0200)
Fixes:
http://autobuild.buildroot.net/results/67ef520d82ea529a9fe593d83a3aeae5f8b0ee5d/
http://autobuild.buildroot.net/results/eafc3e4be571d5ecee549a11530ac4e508f31782/
http://autobuild.buildroot.net/results/ba7f30833fef54162a82f4b336a72d6599594526/

The netsurf build system mixes up host and target CFLAGS, so it isn't
compatible with architectures where we pass ABI specific compiler flags (in
TARGET_ABI).

Add a _ARCH_SUPPORTS kconfig variable matching the TARGET_ABI logic we have
in package/Makefile.in, and use it to disallow netsurf for those
architectures.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/netsurf/Config.in

index 30b26953090a0aa1ae59274861c6202db4160500..4f7d5c2713b46aff823c9c6a236f90a59e2048c8 100644 (file)
@@ -1,10 +1,20 @@
+# netsurf mixes up host and target CFLAGS, so it isn't compatible with
+# architectures where we pass ABI specific compiler flags (TARGET_ABI)
+config BR2_PACKAGE_NETSURF_ARCH_SUPPORTS
+       bool
+       default y if !((BR2_arc && BR2_ARC_ATOMIC_EXT) || \
+               BR2_powerpc_8540 || BR2_powerpc_8548 || BR2_powerpc_e500mc || \
+               BR2_xtensa)
+
 comment "netsurf needs a toolchain w/ dynamic library"
        depends on BR2_STATIC_LIBS
+       depends on BR2_PACKAGE_NETSURF_ARCH_SUPPORTS
 
 config BR2_PACKAGE_NETSURF
        bool "netsurf"
        # static linking support is broken beyond repair
        depends on !BR2_STATIC_LIBS
+       depends on BR2_PACKAGE_NETSURF_ARCH_SUPPORTS
        select BR2_PACKAGE_EXPAT
        select BR2_PACKAGE_JPEG
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE