package/pugixml: force-enable 'long long' support to support gcc<4.8
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Tue, 5 Feb 2019 14:28:26 +0000 (15:28 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 5 Feb 2019 19:44:55 +0000 (20:44 +0100)
Although pugixml will enable 'long long' support automatically if it detects
C++11 (gcc 4.8+), we would like to support older gcc compilers too.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pugixml/pugixml.mk

index acf22604c41e872152eea5de82da3dcdbb2863a8..8edaddd827a6f8586ecd7ee3835e15c39a60f2ad 100644 (file)
@@ -10,6 +10,12 @@ PUGIXML_LICENSE = MIT
 PUGIXML_LICENSE_FILES = readme.txt
 PUGIXML_INSTALL_STAGING = YES
 
+# Pugixml will automatically enable 'long long' support on C++11 compilers,
+# which means gcc 4.8+. As gcc always supports the 'long long' type,
+# force-enable this option to support older gcc versions. See also:
+# https://gcc.gnu.org/onlinedocs/gcc/Long-Long.html
+PUGIXML_BUILD_DEFINES += PUGIXML_HAS_LONG_LONG
+
 ifeq ($(BR2_PACKAGE_PUGIXML_XPATH_SUPPORT),)
 PUGIXML_BUILD_DEFINES += PUGIXML_NO_XPATH
 endif