infra: fix autotools .la fixing when no .la files are present
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Sun, 6 Jul 2014 15:10:51 +0000 (17:10 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 6 Jul 2014 20:22:52 +0000 (22:22 +0200)
Commit 6f638ea9c9c7bacc646430a74ad3dd2740eae676 ("infra: /usr support:
STAGING_DIR can be outside BASE_DIR") changed a for-construct around 'sed
-i' in a 'find | xargs sed -i'. However, if the find returns no results,
sed complains with:
    '/bin/sed: no input files'

This commit adds the extra parameter -r / --no-run-if-empty to the xargs
call, effectively fixing this problem case.

Reported-by: Rohit Kumar <rkthebest@gmail.com>
Fix-suggested-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-autotools.mk

index 432b27f65726019886715ba98ba82b535593f908..ddff9bfbcef3c3dd7f6c86094ad9b35803c3c852 100644 (file)
@@ -281,7 +281,7 @@ endif
 ifndef $(2)_INSTALL_STAGING_CMDS
 define $(2)_INSTALL_STAGING_CMDS
        $$(TARGET_MAKE_ENV) $$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) $$($$(PKG)_INSTALL_STAGING_OPT) -C $$($$(PKG)_SRCDIR)
-       find $$(STAGING_DIR)/usr/lib* -name "*.la" | xargs \
+       find $$(STAGING_DIR)/usr/lib* -name "*.la" | xargs --no-run-if-empty \
                $$(SED) "s:$$(BASE_DIR):@BASE_DIR@:g" \
                        -e "s:$$(STAGING_DIR):@STAGING_DIR@:g" \
                        -e "s:\(['= ]\)/usr:\\1@STAGING_DIR@/usr:g" \