libsigrok: add host-doxygen dependency for C++ bindings
authorBartosz Golaszewski <bgolaszewski@baylibre.com>
Fri, 10 Apr 2015 09:49:58 +0000 (11:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Apr 2015 16:57:13 +0000 (18:57 +0200)
Doxygen is required to generate xml files required by libsigrokcxx
build system.

[Thomas: add host-python (or host-python3) to the dependencies when
building the C++ bindings for libsigrok, since a Python interpreter >=
2.7 is needed at build time.]

Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libsigrok/libsigrok.mk

index 1e6080d0990b71f99cb675364ef9b14b22c78565..2d044b25aac2fa61d17a9795dbdad1356dd1e574 100644 (file)
@@ -48,7 +48,11 @@ endif
 
 ifeq ($(BR2_PACKAGE_LIBSIGROKCXX),y)
 LIBSIGROK_CONF_OPTS += --enable-cxx
-LIBSIGROK_DEPENDENCIES += host-autoconf-archive glibmm
+LIBSIGROK_DEPENDENCIES += \
+       host-autoconf-archive \
+       glibmm \
+       host-doxygen \
+       $(if $(BR2_PACKAGE_PYTHON3),host-python3,host-python)
 else
 LIBSIGROK_CONF_OPTS += --disable-cxx
 endif