projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
86b0f0e
)
package/flannel: Use HOST_GO_TARGET_ENV
author
Geoff Levand
<geoff@infradead.org>
Thu, 26 May 2016 18:21:33 +0000
(18:21 +0000)
committer
Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>
Thu, 26 May 2016 19:04:43 +0000
(21:04 +0200)
Use the newly added HOST_GO_TARGET_ENV variable to pickup the
correct go environment for package builds.
Signed-off-by: Geoff Levand <geoff@infradead.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/flannel/flannel.mk
patch
|
blob
|
history
diff --git
a/package/flannel/flannel.mk
b/package/flannel/flannel.mk
index 876efe69a7972e546e06fd84c455cab0efeb9d47..b5f61a01b946259abe1a73bb1e9c7944aad20ab3 100644
(file)
--- a/
package/flannel/flannel.mk
+++ b/
package/flannel/flannel.mk
@@
-14,9
+14,9
@@
FLANNEL_LICENSE_FILES = LICENSE
FLANNEL_DEPENDENCIES = host-go
FLANNEL_MAKE_ENV = \
+ $(HOST_GO_TARGET_ENV) \
GOBIN="$(@D)/bin" \
GOPATH="$(@D)/gopath" \
- GOARCH=$(GO_GOARCH) \
CGO_ENABLED=1
FLANNEL_GLDFLAGS = \