package/openlayers: new package
authorThomas Claveirole <thomas.claveirole@green-communications.fr>
Thu, 17 Oct 2019 13:18:50 +0000 (15:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 21 Oct 2019 19:47:26 +0000 (21:47 +0200)
Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/Config.in
package/openlayers/Config.in [new file with mode: 0644]
package/openlayers/openlayers.hash [new file with mode: 0644]
package/openlayers/openlayers.mk [new file with mode: 0644]

index c8ff524e83a7bcf65559c8adee5247e8dba46708..e941896ea2155a2229ca1e23e564e7fbd7e3a6ad 100644 (file)
@@ -1473,6 +1473,7 @@ endmenu
 endif
        source "package/jsmin/Config.in"
        source "package/json-javascript/Config.in"
+       source "package/openlayers/Config.in"
 endmenu
 
 menu "JSON/XML"
diff --git a/package/openlayers/Config.in b/package/openlayers/Config.in
new file mode 100644 (file)
index 0000000..a7b7f33
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_OPENLAYERS
+       bool "openlayers"
+       help
+         OpenLayers makes it easy to put a dynamic map in any web
+         page. It can display map tiles, vector data and markers
+         loaded from any source. OpenLayers has been developed to
+         further the use of geographic information of all kinds. It
+         is completely free, Open Source JavaScript, released under
+         the 2-clause BSD License (also known as the FreeBSD).
+
+         https://openlayers.org
diff --git a/package/openlayers/openlayers.hash b/package/openlayers/openlayers.hash
new file mode 100644 (file)
index 0000000..edb6f93
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256 4d62277993108a256fe4d11c02f880f15d4ef184f70e246e52cf1f164ac8ff8b        v6.0.1-dist.zip
diff --git a/package/openlayers/openlayers.mk b/package/openlayers/openlayers.mk
new file mode 100644 (file)
index 0000000..6dadc6d
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# openlayers
+#
+################################################################################
+
+OPENLAYERS_VERSION = 6.0.1
+OPENLAYERS_SOURCE = v$(OPENLAYERS_VERSION)-dist.zip
+OPENLAYERS_SITE = https://github.com/openlayers/openlayers/releases/download/v$(OPENLAYERS_VERSION)
+OPENLAYERS_LICENSE = BSD-2-Clause
+# There's no separate license file in the archive, only minified files.
+
+define OPENLAYERS_EXTRACT_CMDS
+       unzip $(OPENLAYERS_DL_DIR)/$(OPENLAYERS_SOURCE) -d $(@D)
+       mv $(@D)/v$(OPENLAYERS_VERSION)-dist/* $(@D)
+       rmdir $(@D)/v$(OPENLAYERS_VERSION)-dist/
+endef
+
+define OPENLAYERS_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0644 -D -t $(TARGET_DIR)/var/www/ \
+               $(@D)/ol.css $(@D)/ol.js
+endef
+
+$(eval $(generic-package))