- whitespace cleanup (Cristian Ionescu-Idbohrn)
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 1 Sep 2007 18:21:09 +0000 (18:21 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 1 Sep 2007 18:21:09 +0000 (18:21 -0000)
Makefile

index d2aa74066843a692c93e7b2fb5e0f3a916d4ba02..f37b9ede70d5b18764649777bd7c766275a787a1 100644 (file)
--- a/Makefile
+++ b/Makefile
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
 TOPDIR=./
-CONFIG_CONFIG_IN = Config.in
-CONFIG_DEFCONFIG = .defconfig
-CONFIG = package/config
+CONFIG_CONFIG_IN=Config.in
+CONFIG_DEFCONFIG=.defconfig
+CONFIG=package/config
 DATE:=$(shell date -u +%Y%m%d)
 
-noconfig_targets := menuconfig config oldconfig randconfig \
+noconfig_targets:=menuconfig config oldconfig randconfig \
        defconfig allyesconfig allnoconfig release tags \
        source-check help
 
@@ -45,24 +45,24 @@ endif
 # Use 'make V=1' to see the full commands
 ifdef V
   ifeq ("$(origin V)", "command line")
-    KBUILD_VERBOSE = $(V)
+    KBUILD_VERBOSE=$(V)
   endif
 endif
 ifndef KBUILD_VERBOSE
-  KBUILD_VERBOSE = 0
+  KBUILD_VERBOSE=0
 endif
 
 ifeq ($(KBUILD_VERBOSE),1)
   quiet=
-  Q =
+  Q=
 else
   quiet=quiet_
-  Q = @
+  Q=@
 endif
 
-CONFIG_SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
+CONFIG_SHELL:=$(shell if [ -x "$$BASH" ]; then echo $$BASH; \
        else if [ -x /bin/bash ]; then echo /bin/bash; \
-       else echo sh; fi ; fi)
+       else echo sh; fi; fi)
 
 export CONFIG_SHELL quiet Q KBUILD_VERBOSE
 
@@ -85,12 +85,12 @@ endif
 ifndef HOSTLN
 HOSTLN:=ln
 endif
-HOSTAR :=$(shell $(CONFIG_SHELL) -c "which $(HOSTAR)" || type -p $(HOSTAR) || echo ar)
-HOSTAS :=$(shell $(CONFIG_SHELL) -c "which $(HOSTAS)" || type -p $(HOSTAS) || echo as)
-HOSTCC :=$(shell $(CONFIG_SHELL) -c "which $(HOSTCC)" || type -p $(HOSTCC) || echo gcc)
+HOSTAR:=$(shell $(CONFIG_SHELL) -c "which $(HOSTAR)" || type -p $(HOSTAR) || echo ar)
+HOSTAS:=$(shell $(CONFIG_SHELL) -c "which $(HOSTAS)" || type -p $(HOSTAS) || echo as)
+HOSTCC:=$(shell $(CONFIG_SHELL) -c "which $(HOSTCC)" || type -p $(HOSTCC) || echo gcc)
 HOSTCXX:=$(shell $(CONFIG_SHELL) -c "which $(HOSTCXX)" || type -p $(HOSTCXX) || echo g++)
-HOSTLD :=$(shell $(CONFIG_SHELL) -c "which $(HOSTLD)" || type -p $(HOSTLD) || echo ld)
-HOSTLN :=$(shell $(CONFIG_SHELL) -c "which $(HOSTLN)" || type -p $(HOSTLN) || echo ln)
+HOSTLD:=$(shell $(CONFIG_SHELL) -c "which $(HOSTLD)" || type -p $(HOSTLD) || echo ld)
+HOSTLN:=$(shell $(CONFIG_SHELL) -c "which $(HOSTLN)" || type -p $(HOSTLN) || echo ln)
 ifndef CFLAGS_FOR_BUILD
 CFLAGS_FOR_BUILD:=-g -O2
 endif
@@ -100,10 +100,10 @@ export HOSTAR HOSTAS HOSTCC HOSTCXX HOSTLD
 ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 
 # cc-option
-# Usage: cflags-y += $(call cc-option, -march=winchip-c6, -march=i586)
+# Usage: cflags-y+=$(call cc-option, -march=winchip-c6, -march=i586)
 # sets -march=winchip-c6 if supported else falls back to -march=i586
 # without checking the latter.
-cc-option = $(shell if $(TARGET_CC) $(TARGET_CFLAGS) $(1) -S -o /dev/null -xc /dev/null \
+cc-option=$(shell if $(TARGET_CC) $(TARGET_CFLAGS) $(1) -S -o /dev/null -xc /dev/null \
        > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi ;)
 
 #############################################################
@@ -163,7 +163,7 @@ BASE_TARGETS:=uclibc
 endif
 TARGETS:=
 
-# setup uor pathes
+# setup our pathes
 include project/Makefile.in
 
 BR2_DEPENDS_DIR=$(PROJECT_BUILD_DIR)/buildroot-config
@@ -261,9 +261,9 @@ $(PROJECT_BUILD_DIR)/.root:
        mkdir -p $(TARGET_DIR)
        if ! [ -d "$(TARGET_DIR)/bin" ]; then \
                if [ -d "$(TARGET_SKELETON)" ]; then \
-                       cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/ ; \
+                       cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/; \
                fi; \
-               touch $(STAGING_DIR)/.fakeroot.00000 ; \
+               touch $(STAGING_DIR)/.fakeroot.00000; \
        fi
        -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
        -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
@@ -321,13 +321,13 @@ export HOSTCFLAGS
 $(CONFIG)/conf:
        @mkdir -p $(CONFIG)/buildroot-config
        $(MAKE) CC="$(HOSTCC)" -C $(CONFIG) conf
-       -@if [ ! -f .config ] ; then \
+       -@if [ ! -f .config ]; then \
                cp $(CONFIG_DEFCONFIG) .config; \
        fi
 $(CONFIG)/mconf:
        @mkdir -p $(CONFIG)/buildroot-config
        $(MAKE) CC="$(HOSTCC)" -C $(CONFIG) conf mconf
-       -@if [ ! -f .config ] ; then \
+       -@if [ ! -f .config ]; then \
                cp $(CONFIG_DEFCONFIG) .config; \
        fi
 
@@ -388,7 +388,7 @@ source-check: allyesconfig
 #############################################################
 clean:
        rm -f .config .config.old .config.cmd .tmpconfig.h
-       - $(MAKE) -C $(CONFIG) clean
+       -$(MAKE) -C $(CONFIG) clean
 
 distclean: clean
        rm -rf sources/*
@@ -420,5 +420,3 @@ help:
 
 .PHONY: dummy subdirs release distclean clean config oldconfig \
        menuconfig tags check test depend defconfig help
-
-