package/mutt: specify the mailpath
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 29 Nov 2014 10:55:56 +0000 (11:55 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Dec 2014 23:05:05 +0000 (00:05 +0100)
mutt's ./configure looks for different paths for where to look for
incoming mails.

This is absolutely worng in the case of cross-compilation, because the
path it may find on the host may not exist on the target.

Not only that, but some host may not even have any of the paths
./configure looks for.

Fix that by specifying the mailpath, and set it to the value documented
in the FHS [0]

Since Buildroot only guarantees /tmp to be writable, make /var/mail a
symlink to /tmp .

[0] http://refspecs.linuxfoundation.org/FHS_2.3/fhs-2.3.html#VARMAILUSERMAILBOXFILES

Reported-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mutt/mutt.mk

index b4f18b0f7acf608603b312d052126c0b0240ef20..92457a18710785b120e7b436692e0160050eeb8a 100644 (file)
@@ -57,4 +57,11 @@ MUTT_CONF_ENV += \
        mutt_cv_iconv_good=yes \
        mutt_cv_iconv_nontrans=no
 
+MUTT_CONF_OPTS += --with-mailpath=/var/mail
+
+define MUTT_VAR_MAIL
+       ln -sf /tmp $(TARGET_DIR)/var/mail
+endef
+MUTT_POST_INSTALL_TARGET_HOOKS += MUTT_VAR_MAIL
+
 $(eval $(autotools-package))