pkg-infra: DOWNLOAD is never called with two arguments
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 2 Mar 2014 17:51:34 +0000 (18:51 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 2 Mar 2014 20:01:40 +0000 (21:01 +0100)
Currently, the DOWNLOAD helper accepts one or two arguments:
  - the source URI
  - the source filename; if missing, it is derived from the URI

But we have no caller of DOWNLOAD that passes a second argument.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-download.mk

index 6d4cbcded4fc57ce1fff831456cbcdb2fb556a88..85842de354ce09fb9642f12bd96dc5af211f764b 100644 (file)
@@ -238,14 +238,13 @@ endef
 # 3) BR2_BACKUP_SITE if enabled, unless BR2_PRIMARY_SITE_ONLY is set
 #
 # Argument 1 is the source location
-# Argument 2 is the source filename
 #
 # E.G. use like this:
-# $(call DOWNLOAD,$(FOO_SITE),$(FOO_SOURCE))
+# $(call DOWNLOAD,$(FOO_SITE))
 ################################################################################
 
 define DOWNLOAD
-       $(call DOWNLOAD_INNER,$(1),$(if $(2),$(2),$(notdir $(1))))
+       $(call DOWNLOAD_INNER,$(1),$(notdir $(1)))
 endef
 
 define DOWNLOAD_INNER