Makefile: hide commands that build the package file lists at end of build
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 29 Aug 2020 12:20:54 +0000 (14:20 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 29 Aug 2020 12:33:21 +0000 (14:33 +0200)
Since commit 0e2be4db8ab01d479177a3a187c22525752195ae
("package/pkg-generic: make file list logic parallel build
compatible"), the commands executed at the every end of the build
to assemble the list of files installed by the different packages
are visible in the make output. They are quite noisy, and clutter
the output.

The other commands in target-finalize are also hidden using "@",
so we should also do the same for those commands. But that hurts
debuggability, so we use $(Q) (the existing '@'s can be changed
in a followup patch).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
[yann.morin.1998@free.fr: use '$(Q)', not '@']
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Makefile

index 59a5b887b6186fee516dd528860d18b4ada0e4b6..112a7f3b99eb686080017cfe2e0715e9eedc4b35 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -815,11 +815,11 @@ endif # merged /usr
                $(call MESSAGE,"Copying overlay $(d)"); \
                $(call SYSTEM_RSYNC,$(d),$(TARGET_DIR))$(sep))
 
-       $(if $(TARGET_DIR_FILES_LISTS), \
+       $(Q)$(if $(TARGET_DIR_FILES_LISTS), \
                cat $(TARGET_DIR_FILES_LISTS)) > $(BUILD_DIR)/packages-file-list.txt
-       $(if $(HOST_DIR_FILES_LISTS), \
+       $(Q)$(if $(HOST_DIR_FILES_LISTS), \
                cat $(HOST_DIR_FILES_LISTS)) > $(BUILD_DIR)/packages-file-list-host.txt
-       $(if $(STAGING_DIR_FILES_LISTS), \
+       $(Q)$(if $(STAGING_DIR_FILES_LISTS), \
                cat $(STAGING_DIR_FILES_LISTS)) > $(BUILD_DIR)/packages-file-list-staging.txt
 
        @$(foreach s, $(call qstrip,$(BR2_ROOTFS_POST_BUILD_SCRIPT)), \