package/refpolicy: enable systemd support
authorAntoine Tenart <antoine.tenart@bootlin.com>
Fri, 3 Jul 2020 13:19:22 +0000 (15:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 5 Jul 2020 13:35:36 +0000 (15:35 +0200)
This patch enables systemd support in the refpolicy by turning on the
'SYSTEMD' policy build option when systemd is enabled in Buildroot. This
enables conditional rules in SELinux policy modules (by defining
'init_systemd'), to better support systemd.

Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/refpolicy/refpolicy.mk

index a5716f5fcebb1ac8fd0b91ebcbfcb3f643e60062..9346649b2c57d4f05e492e305d9efa7d3e4fd156 100644 (file)
@@ -29,11 +29,18 @@ REFPOLICY_POLICY_VERSION = $(BR2_PACKAGE_LIBSEPOL_POLICY_VERSION)
 REFPOLICY_POLICY_STATE = \
        $(call qstrip,$(BR2_PACKAGE_REFPOLICY_POLICY_STATE))
 
+ifeq ($(BR2_INIT_SYSTEMD),y)
+define REFPOLICY_CONFIGURE_SYSTEMD
+       $(SED) "/SYSTEMD/c\SYSTEMD = y" $(@D)/build.conf
+endef
+endif
+
 define REFPOLICY_CONFIGURE_CMDS
        $(SED) "/OUTPUT_POLICY/c\OUTPUT_POLICY = $(REFPOLICY_POLICY_VERSION)" \
                $(@D)/build.conf
        $(SED) "/MONOLITHIC/c\MONOLITHIC = y" $(@D)/build.conf
        $(SED) "/NAME/c\NAME = targeted" $(@D)/build.conf
+       $(REFPOLICY_CONFIGURE_SYSTEMD)
 endef
 
 define REFPOLICY_BUILD_CMDS