trinity: bump version to fix a build failure using Linux 3.19 headers
authorFabio Porcedda <fabio.porcedda@gmail.com>
Sun, 22 Feb 2015 21:29:33 +0000 (22:29 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 23 Feb 2015 11:27:09 +0000 (12:27 +0100)
bump to the following trinity repository commit:

kvm: Add ifdef around IA64 ioctls.
Fix build error.

  CC ioctls/kvm.o
In file included from ioctls/kvm.c:8:0:
ioctls/kvm.c:115:8: error: ‘KVM_IA64_VCPU_GET_STACK’ undeclared here (not in a function)
  IOCTL(KVM_IA64_VCPU_GET_STACK),
        ^
include/ioctls.h:53:15: note: in definition of macro ‘IOCTL’
  { .request = _request, .name = #_request, }
               ^
ioctls/kvm.c:116:8: error: ‘KVM_IA64_VCPU_SET_STACK’ undeclared here (not in a function)
  IOCTL(KVM_IA64_VCPU_SET_STACK),
        ^
include/ioctls.h:53:15: note: in definition of macro ‘IOCTL’
  { .request = _request, .name = #_request, }

IA64 ioctls were removed in Linux 3.19.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/trinity/trinity.mk

index 52805e0c924cec43368283320a76da8204d9d950..5f8a7074670137014bf698e13ac060c99e841e5a 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-TRINITY_VERSION = 5d2dfe9727eb9c8dc44c31e95968e8d85284ffcc
+TRINITY_VERSION = c8c41f99500b5854c2061a08962b8908c872d852
 TRINITY_SITE = $(call github,kernelslacker,trinity,$(TRINITY_VERSION))
 TRINITY_LICENSE = GPLv2
 TRINITY_LICENSE_FILES = COPYING