flann: disallow static library build
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 13 May 2014 20:45:37 +0000 (22:45 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 13 May 2014 21:44:36 +0000 (23:44 +0200)
Even though flann build system uses CMake, it always tries to build a
shared library, even if BUILD_SHARED_LIBS=OFF is passed. It could
probably be fixed in flann's CMakeLists.txt, but that's not really
worth the effort if upstream doesn't support it.

Therefore, we simply disallow the flann package in purely static
builds.

Fixes:

  http://autobuild.buildroot.org/results/a4e/a4ec0e9f28cd12ce770718fb407bbb4dc93b528b/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/flann/Config.in

index 4b0b5a8cf31b37fb19006ab541fbb7f959e4a72c..6185b1292d2744165c94330591a142f368296031 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_FLANN
        bool "flann"
        depends on BR2_INSTALL_LIBSTDCPP
+       depends on !BR2_PREFER_STATIC_LIB
        help
          FLANN is a library for performing fast approximate nearest
          neighbor searches in high dimensional spaces. It contains a
@@ -20,5 +21,5 @@ config BR2_PACKAGE_FLANN_EXAMPLES
 
 endif
 
-comment "flann needs a toolchain w/ C++"
-       depends on !BR2_INSTALL_LIBSTDCPP
+comment "flann needs a toolchain w/ C++, dynamic library"
+       depends on !BR2_INSTALL_LIBSTDCPP || BR2_PREFER_STATIC_LIB