package/janus-gateway: add systemd socket support
authorAdam Duskett <Aduskett@gmail.com>
Sun, 14 Jun 2020 21:19:13 +0000 (14:19 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 18 Jun 2020 20:14:19 +0000 (22:14 +0200)
If systemd is selected, add the systemd package to the dependency list and set
the conf opt --enable-systemd-sockets.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/janus-gateway/janus-gateway.mk

index 0ecd83fce1429e8d06e7526f7d68e6a9fe90aae5..56b7d67332815d270e068222efd0d9ede7ea2fd6 100644 (file)
@@ -112,4 +112,11 @@ else
 JANUS_GATEWAY_CONF_OPTS += --disable-websockets
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+JANUS_GATEWAY_DEPENDENCIES += systemd
+JANUS_GATEWAY_CONF_OPTS += --enable-systemd-sockets
+else
+JANUS_GATEWAY_CONF_OPTS += --disable-systemd-sockets
+endif
+
 $(eval $(autotools-package))