package/webrtc-audio-processing: bump to version 0.3.1
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 27 Nov 2019 09:19:09 +0000 (10:19 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 3 Dec 2019 07:32:26 +0000 (08:32 +0100)
Drop 0001-configure.ac-fix-architecture-detection.patch as it is now
upstream.  Aarch64 is now supported, so update _ARCH_SUPPORTS to match.

Add a hash for the license file.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/webrtc-audio-processing/0001-Proper-detection-of-cxxabi.h-and-execinfo.h.patch [new file with mode: 0644]
package/webrtc-audio-processing/0001-configure.ac-fix-architecture-detection.patch [deleted file]
package/webrtc-audio-processing/0002-Proper-detection-of-cxxabi.h-and-execinfo.h.patch [deleted file]
package/webrtc-audio-processing/Config.in
package/webrtc-audio-processing/webrtc-audio-processing.hash
package/webrtc-audio-processing/webrtc-audio-processing.mk

diff --git a/package/webrtc-audio-processing/0001-Proper-detection-of-cxxabi.h-and-execinfo.h.patch b/package/webrtc-audio-processing/0001-Proper-detection-of-cxxabi.h-and-execinfo.h.patch
new file mode 100644 (file)
index 0000000..a0332db
--- /dev/null
@@ -0,0 +1,63 @@
+From b7a166acaddc4c78afa2b653e25114d9114699f3 Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Sat, 6 Aug 2016 11:24:50 +0200
+Subject: [PATCH] Proper detection of cxxabi.h and execinfo.h
+
+The current code in webrtc/base/checks.cc assumes that if __GLIBCXX__ is
+defined and __UCLIBC__ is not defined, then both cxxabi.h and execinfo.h
+will be available.
+
+Unfortunately, this is not correct with the musl C library:
+
+ - It defines __GLIBCXX__
+ - It does not define __UCLIBC__ (it's not uClibc after all!)
+ - But it also doesn't provide execinfo.h
+
+Therefore, in order to make things work properly, we switch to proper
+autoconf checks for cxxabi.h and execinfo.h, and only use the backtrace
+functionality if both are provided.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ configure.ac          | 2 ++
+ webrtc/base/checks.cc | 4 ++--
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index acbb3e2..ff4c752 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -45,6 +45,8 @@ AC_SUBST(GNUSTL_CFLAGS)
+ # Borrowed from gst-plugins-bad
+ AC_CHECK_HEADER(MobileCoreServices/MobileCoreServices.h, HAVE_IOS="yes", HAVE_IOS="no", [-])
++AC_CHECK_HEADERS([cxxabi.h execinfo.h])
++
+ # Based on gst-plugins-bad configure.ac and defines in
+ # <chromium source>/build/config/BUILDCONFIG.gn and
+ # webrtc/BUILD.gn
+diff --git a/webrtc/base/checks.cc b/webrtc/base/checks.cc
+index 49a31f2..05d23a6 100644
+--- a/webrtc/base/checks.cc
++++ b/webrtc/base/checks.cc
+@@ -16,7 +16,7 @@
+ #include <cstdio>
+ #include <cstdlib>
+-#if defined(__GLIBCXX__) && !defined(__UCLIBC__)
++#if defined(HAVE_CXX_ABI_H) && defined(HAVE_EXECINFO_H)
+ #include <cxxabi.h>
+ #include <execinfo.h>
+ #endif
+@@ -55,7 +55,7 @@ void PrintError(const char* format, ...) {
+ // to get usable symbols on Linux. This is copied from V8. Chromium has a more
+ // advanced stace trace system; also more difficult to copy.
+ void DumpBacktrace() {
+-#if defined(__GLIBCXX__) && !defined(__UCLIBC__)
++#if defined(HAVE_CXX_ABI_H) && defined(HAVE_EXECINFO_H)
+   void* trace[100];
+   int size = backtrace(trace, sizeof(trace) / sizeof(*trace));
+   char** symbols = backtrace_symbols(trace, size);
+-- 
+2.7.4
+
diff --git a/package/webrtc-audio-processing/0001-configure.ac-fix-architecture-detection.patch b/package/webrtc-audio-processing/0001-configure.ac-fix-architecture-detection.patch
deleted file mode 100644 (file)
index d0ea4bd..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-From 233413841882608c6d5b98b6ce89fcb8a292db82 Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Sat, 6 Aug 2016 10:22:34 +0200
-Subject: [PATCH] configure.ac: fix architecture detection
-
-The current architecture detection, based on the "host_cpu" part of the
-tuple does not work properly for a number of reason:
-
- - The code assumes that if host_cpu starts with "arm" then ARM
-   instructions are available, which is incorrect. Indeed, Cortex-M
-   platforms can run Linux, they are ARM platforms (so host_cpu = arm),
-   but they don't support ARM instructions: they support only the
-   Thumb-2 instruction set.
-
- - The armv7 case is also not very useful, as it is not standard at all
-   to pass armv7 as host_cpu even if the host system is actually ARMv7
-   based.
-
- - For the same reason, the armv8 case is not very useful: armv8 is
-   never used as the host_cpu part of a tuple.
-
-So, this commit moves away from a host_cpu based logic, and instead
-tests using AC_CHECK_DECLS() the built-in definitions of the compiler:
-
- - If we have __ARM_ARCH_ISA_ARM defined, then it's an ARM processor
-   that supports the ARM instruction set (this allows to exclude Thumb-2
-   only processors).
-
- - If we have __ARM_ARCH_7A__, then we have an ARMv7-A processor, and
-   we can enable the corresponding optimizations
-
- - Same for __i386__ and __x86_64__.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
-Submitted upstream, under a slightly different form so that it applies
-on master:
-
-  https://lists.freedesktop.org/archives/pulseaudio-discuss/2016-August/026600.html
----
- configure.ac | 27 +++++++++------------------
- 1 file changed, 9 insertions(+), 18 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 6f9553b..836c6ad 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -55,24 +55,15 @@ AS_CASE(["${host}"],
- )
- AC_SUBST(PLATFORM_CFLAGS)
--AS_CASE(["${host_cpu}"],
--    [i?86|x86_64],
--        [
--         HAVE_X86=1
--        ],
--    [armv7*|armv8*],
--        [
--         HAVE_ARM=1
--         HAVE_ARMV7=1
--         ARCH_CFLAGS="-DWEBRTC_ARCH_ARM -DWEBRTC_ARCH_ARM_V7"
--        ],
--    [arm*],
--        [
--         HAVE_ARM=1
--         ARCH_CFLAGS="-DWEBRTC_ARCH_ARM"
--        ]
--    # FIXME: Add MIPS support, see webrtc/BUILD.gn for defines
--)
-+# Testing __ARM_ARCH_ISA_ARM since the code contains ARM instructions,
-+# which don't work on Thumb-2 only platforms (ARMv7-M).
-+AC_CHECK_DECLS([__ARM_ARCH_ISA_ARM],
-+      [HAVE_ARM=1; ARCH_CFLAGS="${ARCH_CFLAGS} -DWEBRTC_ARCH_ARM"])
-+AC_CHECK_DECLS([__ARM_ARCH_7A__],
-+      [HAVE_ARMV7=1; ARCH_CFLAGS="${ARCH_CFLAGS} -DWEBRTC_ARCH_ARM_V7"])
-+AC_CHECK_DECLS([__i386__], [HAVE_X86=1])
-+AC_CHECK_DECLS([__x86_64__], [HAVE_X86=1])
-+
- AM_CONDITIONAL(HAVE_X86, [test "x${HAVE_X86}" = "x1"])
- AM_CONDITIONAL(HAVE_ARM, [test "x${HAVE_ARM}" = "x1"])
- AM_CONDITIONAL(HAVE_ARMV7, [test "x${HAVE_ARMV7}" = "x1"])
--- 
-2.7.4
-
diff --git a/package/webrtc-audio-processing/0002-Proper-detection-of-cxxabi.h-and-execinfo.h.patch b/package/webrtc-audio-processing/0002-Proper-detection-of-cxxabi.h-and-execinfo.h.patch
deleted file mode 100644 (file)
index a0332db..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-From b7a166acaddc4c78afa2b653e25114d9114699f3 Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Sat, 6 Aug 2016 11:24:50 +0200
-Subject: [PATCH] Proper detection of cxxabi.h and execinfo.h
-
-The current code in webrtc/base/checks.cc assumes that if __GLIBCXX__ is
-defined and __UCLIBC__ is not defined, then both cxxabi.h and execinfo.h
-will be available.
-
-Unfortunately, this is not correct with the musl C library:
-
- - It defines __GLIBCXX__
- - It does not define __UCLIBC__ (it's not uClibc after all!)
- - But it also doesn't provide execinfo.h
-
-Therefore, in order to make things work properly, we switch to proper
-autoconf checks for cxxabi.h and execinfo.h, and only use the backtrace
-functionality if both are provided.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- configure.ac          | 2 ++
- webrtc/base/checks.cc | 4 ++--
- 2 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index acbb3e2..ff4c752 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -45,6 +45,8 @@ AC_SUBST(GNUSTL_CFLAGS)
- # Borrowed from gst-plugins-bad
- AC_CHECK_HEADER(MobileCoreServices/MobileCoreServices.h, HAVE_IOS="yes", HAVE_IOS="no", [-])
-+AC_CHECK_HEADERS([cxxabi.h execinfo.h])
-+
- # Based on gst-plugins-bad configure.ac and defines in
- # <chromium source>/build/config/BUILDCONFIG.gn and
- # webrtc/BUILD.gn
-diff --git a/webrtc/base/checks.cc b/webrtc/base/checks.cc
-index 49a31f2..05d23a6 100644
---- a/webrtc/base/checks.cc
-+++ b/webrtc/base/checks.cc
-@@ -16,7 +16,7 @@
- #include <cstdio>
- #include <cstdlib>
--#if defined(__GLIBCXX__) && !defined(__UCLIBC__)
-+#if defined(HAVE_CXX_ABI_H) && defined(HAVE_EXECINFO_H)
- #include <cxxabi.h>
- #include <execinfo.h>
- #endif
-@@ -55,7 +55,7 @@ void PrintError(const char* format, ...) {
- // to get usable symbols on Linux. This is copied from V8. Chromium has a more
- // advanced stace trace system; also more difficult to copy.
- void DumpBacktrace() {
--#if defined(__GLIBCXX__) && !defined(__UCLIBC__)
-+#if defined(HAVE_CXX_ABI_H) && defined(HAVE_EXECINFO_H)
-   void* trace[100];
-   int size = backtrace(trace, sizeof(trace) / sizeof(*trace));
-   char** symbols = backtrace_symbols(trace, size);
--- 
-2.7.4
-
index 02715b080a03ae9b4abf9ecb17e0ff6ec4c23641..64138269b556b8aa777b7a0a67f348618625c5a5 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING_ARCH_SUPPORTS
        bool
-       default y if BR2_arm || BR2_i386 || BR2_x86_64
+       default y if BR2_aarch64 || BR2_arm || BR2_i386 || BR2_x86_64
 
 config BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING
        bool "webrtc-audio-processing"
index fe071191608456905a2c69e0b8215de4517275e9..1376054f20805cf1b2ecf31d3cef3ba24541c6dd 100644 (file)
@@ -1,2 +1,3 @@
 # Locally calculated
-sha256 756e291d4f557d88cd50c4fe3b8454ec238362d22cedb3e6173240d90f0a80fa  webrtc-audio-processing-0.3.tar.xz
+sha256 a0fdd938fd85272d67e81572c5a4d9e200a0c104753cb3c209ded175ce3c5dbf  webrtc-audio-processing-0.3.1.tar.xz
+sha256 9b79539028e216e813e152d45f5c1ed5fdd0554426ad50270fb03134e7082dac  COPYING
index 668e20d73000655211a5cefac015c2896ce7f3c4..7edeaf961f2ab971ff344a8ca9c95d0947ba9614 100644 (file)
@@ -4,14 +4,13 @@
 #
 ################################################################################
 
-WEBRTC_AUDIO_PROCESSING_VERSION = 0.3
+WEBRTC_AUDIO_PROCESSING_VERSION = 0.3.1
 WEBRTC_AUDIO_PROCESSING_SOURCE = webrtc-audio-processing-$(WEBRTC_AUDIO_PROCESSING_VERSION).tar.xz
 WEBRTC_AUDIO_PROCESSING_SITE = http://freedesktop.org/software/pulseaudio/webrtc-audio-processing
 WEBRTC_AUDIO_PROCESSING_INSTALL_STAGING = YES
 WEBRTC_AUDIO_PROCESSING_LICENSE = BSD-3-Clause
 WEBRTC_AUDIO_PROCESSING_LICENSE_FILES = COPYING
-# 0001-configure.ac-fix-architecture-detection.patch
-# 0002-Proper-detection-of-cxxabi.h-and-execinfo.h.patch
+# 0001-Proper-detection-of-cxxabi.h-and-execinfo.h.patch
 WEBRTC_AUDIO_PROCESSING_AUTORECONF = YES
 
 ifeq ($(BR2_SOFT_FLOAT),y)