package/strace: enable demangling of C++ symbol names in stack trace
authorRomain Naour <romain.naour@gmail.com>
Sun, 25 Feb 2018 18:34:15 +0000 (19:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 20 May 2018 14:57:22 +0000 (16:57 +0200)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/strace/strace.mk

index 4d42085819de420d6040e975b4d35f165a2c7857..7b3ff184fb6e440c0b2277cb58dfd19f5bace371 100644 (file)
@@ -18,6 +18,14 @@ else
 STRACE_CONF_OPTS += --without-libunwind
 endif
 
+# Demangling symbols in stack trace needs libunwind and libiberty.
+ifeq ($(BR2_PACKAGE_BINUTILS)$(BR2_PACKAGE_LIBUNWIND),yy)
+STRACE_DEPENDENCIES += binutils
+STRACE_CONF_OPTS += --with-libiberty=check
+else
+STRACE_CONF_OPTS += --without-libiberty
+endif
+
 define STRACE_REMOVE_STRACE_GRAPH
        rm -f $(TARGET_DIR)/usr/bin/strace-graph
 endef