Build libusb without annoying tests, breaking the build
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Tue, 25 Sep 2007 12:54:48 +0000 (12:54 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Tue, 25 Sep 2007 12:54:48 +0000 (12:54 -0000)
package/libusb/libusb.mk

index 4e06dc88393f6e037e71752a5db53a77324f0517..a192e2d92c88b8eb40eada83b6f92e490130aa95 100644 (file)
@@ -29,6 +29,9 @@ $(LIBUSB_DIR)/.unpacked: $(DL_DIR)/$(LIBUSB_SOURCE)
 ifneq ($(LIBUSB_PATCH_FILE),)
        (cd $(LIBUSB_DIR) && $(LIBUSB_CAT) $(LIBUSB_PATCH) | patch -p1)
 endif
+       toolchain/patch-kernel.sh $(LIBUSB_DIR) package/libusb/ libusb-$(LIBUSB_VERSION)\*.patch*
+       $(SED) 's,^all:.*,all:,g' $(LIBUSB_DIR)/tests/Makefile.in
+       $(SED) 's,^install:.*,install:,g' $(LIBUSB_DIR)/tests/Makefile.in
        touch $@
 
 $(LIBUSB_DIR)/.configured: $(LIBUSB_DIR)/.unpacked