qt: install QML imports on target
authorDaniel Nyström <daniel.nystrom@timeterminal.se>
Wed, 20 Feb 2013 00:18:51 +0000 (00:18 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 27 Feb 2013 22:57:50 +0000 (23:57 +0100)
When selecting the Qt declarative module, all the QML imports was
built and installed to staging, but never installed to the target.

Signed-off-by: Daniel Nyström <daniel.nystrom@timeterminal.se>
Acked-by: Alexander Lukichev <alexander.lukichev@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/qt.mk

index ee1a88b7ac54088d9cb6fbaf1102ef18da2a0f4b..376781057fe1a952e0e4e9cc75769b1e02bc7046 100644 (file)
@@ -498,6 +498,7 @@ define QT_CONFIGURE_CMDS
                -no-separate-debug-info \
                -prefix /usr \
                -plugindir /usr/lib/qt/plugins \
+               -importdir /usr/lib/qt/imports \
                -hostprefix $(STAGING_DIR) \
                -fast \
                -no-rpath \
@@ -610,6 +611,14 @@ define QT_INSTALL_TARGET_PLUGINS
        fi
 endef
 
+# Import installation
+define QT_INSTALL_TARGET_IMPORTS
+       if [ -d $(STAGING_DIR)/usr/lib/qt/imports/ ] ; then \
+               mkdir -p $(TARGET_DIR)/usr/lib/qt/imports ; \
+               cp -dpfr $(STAGING_DIR)/usr/lib/qt/imports/* $(TARGET_DIR)/usr/lib/qt/imports ; \
+       fi
+endef
+
 # Fonts installation
 ifneq ($(QT_FONTS),)
 define QT_INSTALL_TARGET_FONTS
@@ -628,6 +637,7 @@ endif
 define QT_INSTALL_TARGET_CMDS
        $(QT_INSTALL_TARGET_LIBS)
        $(QT_INSTALL_TARGET_PLUGINS)
+       $(QT_INSTALL_TARGET_IMPORTS)
        $(QT_INSTALL_TARGET_FONTS)
        $(QT_INSTALL_TARGET_FONTS_TTF)
 endef