ffmpeg: remove example source code from target
authorDanomi Manchego <danomimanchego123@gmail.com>
Thu, 16 Feb 2017 03:13:29 +0000 (22:13 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 17 Feb 2017 15:25:48 +0000 (16:25 +0100)
There does not appear to be a way to configure the example code
installation, so this mod gets rid of it with a post-install hook.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ffmpeg/ffmpeg.mk

index 4447b724c4e9e301c14090f2d213fd8ad29c5ce6..449cca2ce36cdcabb3593af3df756933dfb7a584 100644 (file)
@@ -496,4 +496,9 @@ define FFMPEG_CONFIGURE_CMDS
        )
 endef
 
+define FFMPEG_REMOVE_EXAMPLE_SRC_FILES
+       rm -rf $(TARGET_DIR)/usr/share/ffmpeg/examples
+endef
+FFMPEG_POST_INSTALL_TARGET_HOOKS += FFMPEG_REMOVE_EXAMPLE_SRC_FILES
+
 $(eval $(autotools-package))