fbterm: fix linking issue when static linking and a toolchain with threads
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 11 May 2015 20:26:39 +0000 (22:26 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 11 May 2015 20:26:39 +0000 (22:26 +0200)
Fixes:
http://autobuild.buildroot.net/results/899/899eb7e36dc31b7dcb51c0dd23d91965111d22c4/
http://autobuild.buildroot.net/results/43a/43a34d8b64f536caa579709508bb5e00633ba6e7/
http://autobuild.buildroot.net/results/f34/f343d015b127f29d614e7ea38b173d3a5c270d84/
http://autobuild.buildroot.net/results/da8/da88f40dfc51aea122c146e5bfee19b031cfaab6/

And many more.

Fontconfig uses pthreads if available, but fbterm forgets to link with it
breaking static builds.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/fbterm/fbterm.mk

index 7e9d32441c0cffb8978c0a5428886578fd8615af..d78d6b75af13eff9e0b1a2e28d8d12a463e33cef 100644 (file)
@@ -10,4 +10,10 @@ FBTERM_LICENSE = GPLv2+
 FBTERM_LICENSE_FILES = COPYING
 FBTERM_DEPENDENCIES = fontconfig liberation
 
+ifeq ($(BR2_STATIC_LIBS)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
+# fontconfig uses pthreads if available, but fbterm forgets to link
+# with it breaking static builds
+FBTERM_CONF_ENV += LIBS='-lpthread'
+endif
+
 $(eval $(autotools-package))