qt4: allow separate build/installation of demos and examples
authorJulien Boibessot <julien.boibessot@armadeus.com>
Mon, 6 Jan 2014 21:43:02 +0000 (22:43 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 9 Jan 2014 20:03:58 +0000 (21:03 +0100)
Signed-off-by: Jeremie Scheer <jeremie.scheer@armadeus.com>
Signed-off-by: Julien Boibessot <julien.boibessot@armadeus.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt/Config.in
package/qt/qt.mk

index dd2b6d9ec9873ff06e4fe749f06888879e634059..926d54c619635c9c84bf21cd7b80df8a5b05ed89 100644 (file)
@@ -21,7 +21,13 @@ config BR2_PACKAGE_QT_DEBUG
          If unsure, say N.
 
 config BR2_PACKAGE_QT_DEMOS
-       bool "Compile and install demos and examples (with code)"
+       bool "Compile and install Qt demos (with code)"
+       select BR2_PACKAGE_QT_GUI_MODULE
+       help
+         If unsure, say N.
+
+config BR2_PACKAGE_QT_EXAMPLES
+       bool "Compile and install Qt examples (with code)"
        select BR2_PACKAGE_QT_GUI_MODULE
        help
          If unsure, say N.
index 029d317974335a4cc9cf67f8cd3b42ab111f94f8..867b79867c40d83cf0e98e84b6a44b0dd7b6409a 100644 (file)
@@ -59,9 +59,14 @@ QT_CONFIGURE_OPTS += -no-qt3support
 endif
 
 ifeq ($(BR2_PACKAGE_QT_DEMOS),y)
-QT_CONFIGURE_OPTS += -examplesdir $(TARGET_DIR)/usr/share/qt/examples -demosdir $(TARGET_DIR)/usr/share/qt/demos
+QT_CONFIGURE_OPTS += -demosdir $(TARGET_DIR)/usr/share/qt/demos
 else
-QT_CONFIGURE_OPTS += -nomake examples -nomake demos
+QT_CONFIGURE_OPTS += -nomake demos
+endif
+ifeq ($(BR2_PACKAGE_QT_EXAMPLES),y)
+QT_CONFIGURE_OPTS += -examplesdir $(TARGET_DIR)/usr/share/qt/examples
+else
+QT_CONFIGURE_OPTS += -nomake examples
 endif
 
 # ensure glib is built first if enabled for Qt's glib support