package/samba4: bump version to 4.9.0
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 15 Sep 2018 18:16:30 +0000 (20:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 16 Sep 2018 13:11:45 +0000 (15:11 +0200)
Release notes: https://www.samba.org/samba/history/samba-4.9.0.html

Added optional dependency to libarchive to fix configure error:

Checking for libarchive existence
Checking for header archive.h        : no
/home/buildroot/br5/output/build/samba4-4.9.0/source3/wscript:225:
 error: libarchive support not found. Try installing libarchive-dev or
 libarchive-devel. Otherwise, use --without-libarchive to build without
 libarchive support. libarchive support is required for the smbclient
 tar-file mode

Disabled gpgme support to fix configure error:

Checking for program gpgme-config    : not found
Checking for library gpgme           : not found
Checking for gpgme_new               : not found
/home/buildroot/br5/output/build/samba4-4.9.0/source4/dsdb/samdb/ldb_modules/wscript:40:
 error: GPGME support not found. Try installing libgpgme11-dev or
 gpgme-devel and python-gpgme. Otherwise, use --without-gpgme to build
 without GPGME support or --without-ad-dc to build without the Samba AD
 DC. GPGME support is required for the GPG encrypted password sync
 feature

Buildroot has no python-gpgme package atm so we disable this option
for now.

Disabled experimental LMDB LDB backend as well, this also needed an
addition to samba4-cache.txt.

AD DC support needs jansson, for details see release notes.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/samba4/Config.in
package/samba4/samba4-cache.txt
package/samba4/samba4.hash
package/samba4/samba4.mk

index 298fdc6608efabddc189b03a709ef470831dbd1d..4ccd22aa2d087a9fce671f753ebb9ef150693dfc 100644 (file)
@@ -30,6 +30,7 @@ if BR2_PACKAGE_SAMBA4
 config BR2_PACKAGE_SAMBA4_AD_DC
        bool "AD DC"
        select BR2_PACKAGE_GNUTLS
+       select BR2_PACKAGE_JANSSON
        help
          Enable Active Directory Domain Controller functionality.
 
index 0485f0dbb18090b35795e5be1b48b33000ba3793..e3a3720fc8d58b14ac232523b401a167860796da 100644 (file)
@@ -39,3 +39,4 @@ Checking value of SIGRTMAX: "64"
 Checking value of SIGRTMIN: "34"
 Checking errno of iconv for illegal multibyte sequence: "0"
 checking for clnt_create(): OK
+Checking for a 64-bit host to support lmdb: NO
index 9594c7a932e157cd4a20a00ae92470eee5407337..b01ece7b6709c268b1556c744e0bc3e882906162 100644 (file)
@@ -1,4 +1,4 @@
 # Locally calculated after checking pgp signature
-# https://download.samba.org/pub/samba/stable/samba-4.8.5.tar.asc
-sha256 e58ee6b1262d4128b8932ceee59d5f0b0a9bbe00547eb3cc4c41552de1a65155  samba-4.8.5.tar.gz
+# https://download.samba.org/pub/samba/stable/samba-4.9.0.tar.asc
+sha256 d071e9e738e9583d0b9ce1c758d46808b76078405787c88a0c5b465bef8a9b15  samba-4.9.0.tar.gz
 sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  COPYING
index 2db7a81df3c05cb49a2ea4a7c1ca056c348b0905..c7aaf6ba2927ce8ef66d53de896d2d4256ba5040 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-SAMBA4_VERSION = 4.8.5
+SAMBA4_VERSION = 4.9.0
 SAMBA4_SITE = https://download.samba.org/pub/samba/stable
 SAMBA4_SOURCE = samba-$(SAMBA4_VERSION).tar.gz
 SAMBA4_INSTALL_STAGING = YES
@@ -69,6 +69,13 @@ else
 SAMBA4_CONF_OPTS += --disable-gnutls
 endif
 
+ifeq ($(BR2_PACKAGE_LIBARCHIVE),y)
+SAMBA4_CONF_OPTS += --with-libarchive
+SAMBA4_DEPENDENCIES += libarchive
+else
+SAMBA4_CONF_OPTS += --without-libarchive
+endif
+
 ifeq ($(BR2_PACKAGE_NCURSES),y)
 SAMBA4_CONF_ENV += NCURSES_CONFIG="$(STAGING_DIR)/usr/bin/$(NCURSES_CONFIG_SCRIPTS)"
 SAMBA4_DEPENDENCIES += ncurses
@@ -108,6 +115,8 @@ define SAMBA4_CONFIGURE_CMDS
                        --disable-iprint \
                        --without-pam \
                        --without-dmapi \
+                       --without-gpgme \
+                       --without-ldb-lmdb \
                        --disable-glusterfs \
                        --with-cluster-support \
                        --bundled-libraries='!asn1_compile,!compile_et' \
@@ -127,8 +136,10 @@ define SAMBA4_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
 endef
 
-ifeq ($(BR2_PACKAGE_SAMBA4_AD_DC),)
-SAMBA4_CONF_OPTS += --without-ad-dc
+ifeq ($(BR2_PACKAGE_SAMBA4_AD_DC),y)
+SAMBA4_DEPENDENCIES += jansson
+else
+SAMBA4_CONF_OPTS += --without-ad-dc --without-json-audit
 endif
 
 ifeq ($(BR2_PACKAGE_SAMBA4_ADS),y)