added ngspice-rework
authorJohn Voltz <john.voltz@gmail.com>
Thu, 6 Mar 2008 18:19:42 +0000 (18:19 -0000)
committerJohn Voltz <john.voltz@gmail.com>
Thu, 6 Mar 2008 18:19:42 +0000 (18:19 -0000)
package/ng-spice-rework/Config.in [new file with mode: 0644]
package/ng-spice-rework/ng-spice-rework-17-makeidx.patch [new file with mode: 0644]
package/ng-spice-rework/ng-spice-rework.mk [new file with mode: 0644]

diff --git a/package/ng-spice-rework/Config.in b/package/ng-spice-rework/Config.in
new file mode 100644 (file)
index 0000000..730fea7
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_NG_SPICE_REWORK
+       bool "ng-spice-rework"
+       default n
+       help
+         Ngspice is a mixed-level/mixed-signal circuit simulator.
+
+         http://superb-west.dl.sourceforge.net/sourceforge/ngspice
diff --git a/package/ng-spice-rework/ng-spice-rework-17-makeidx.patch b/package/ng-spice-rework/ng-spice-rework-17-makeidx.patch
new file mode 100644 (file)
index 0000000..dcce6ce
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/src/Makefile.in  2005-08-30 03:58:00.000000000 -0400
++++ b/src/Makefile.in  2008-02-13 14:38:04.000000000 -0500
+@@ -882,7 +882,8 @@ spice.o: main.c
+               $(COMPILE) -DSIMULATOR -o spice.o  -c $(srcdir)/main.c
+ ngspice.idx: makeidx
+-      ./makeidx $(srcdir)/ngspice.txt
++      gcc -I/usr/include -I.. -I./include $(makeidx_SOURCES) -o makeidx-host
++      ./makeidx-host $(srcdir)/ngspice.txt
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/package/ng-spice-rework/ng-spice-rework.mk b/package/ng-spice-rework/ng-spice-rework.mk
new file mode 100644 (file)
index 0000000..205fe22
--- /dev/null
@@ -0,0 +1,18 @@
+#############################################################
+#
+# ng-spice-rework
+#
+#############################################################
+NG_SPICE_REWORK_VERSION = 17
+NG_SPICE_REWORK_SOURCE = ng-spice-rework-$(NG_SPICE_REWORK_VERSION).tar.gz
+NG_SPICE_REWORK_SITE = http://superb-west.dl.sourceforge.net/sourceforge/ngspice
+NG_SPICE_REWORK_AUTORECONF = NO
+NG_SPICE_REWORK_INSTALL_STAGING = NO
+NG_SPICE_REWORK_INSTALL_TARGET = YES
+
+NG-SPICE-REWORK_CONF_OPT = 
+
+NG-SPICE-REWORK_DEPENDENCIES = uclibc 
+
+$(eval $(call AUTOTARGETS,package,ng-spice-rework))
+