package/libva: fix mesa3d glx support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 1 Oct 2019 06:05:20 +0000 (08:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 8 Oct 2019 21:31:02 +0000 (23:31 +0200)
https://git.buildroot.net/buildroot/commit/package/mesa3d?id=5cb821d5635626b7327d5d704555c412e5ed5a1f

added a new option to enable GLX support.

This patch adjusts libva to use the new logic.

Fixes:
http://autobuild.buildroot.net/results/797/79776104e681402c24160be15789fe67bb69f833/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libva/libva.mk

index 7bf1839f4c2370915258c417a7a7e952277dbda1..6c8243da905dbebe9a9fb7249c87e70d1fe4c530 100644 (file)
@@ -20,7 +20,7 @@ LIBVA_CONF_OPTS = \
 ifeq ($(BR2_PACKAGE_XORG7),y)
 LIBVA_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXfixes
 LIBVA_CONF_OPTS += --enable-x11
-ifeq ($(BR2_PACKAGE_MESA3D_DRI_DRIVER),y)
+ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_GLX),y)
 LIBVA_DEPENDENCIES += mesa3d
 LIBVA_CONF_OPTS += --enable-glx
 endif