projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3c79729
)
Fix the condition for applying the i386 soft float patch.
author
Manuel Novoa III
<mjn3@codepoet.org>
Mon, 24 Nov 2003 20:50:12 +0000
(20:50 -0000)
committer
Manuel Novoa III
<mjn3@codepoet.org>
Mon, 24 Nov 2003 20:50:12 +0000
(20:50 -0000)
make/gcc-3.3.mk
patch
|
blob
|
history
diff --git
a/make/gcc-3.3.mk
b/make/gcc-3.3.mk
index a129bd875d44fd945473b0ba3c3e5d2560280ba3..0a12d043c8764547c27982b93641573e7e1ccd86 100644
(file)
--- a/
make/gcc-3.3.mk
+++ b/
make/gcc-3.3.mk
@@
-67,7
+67,7
@@
$(GCC_DIR)/.unpacked: $(DL_DIR)/$(GCC_SOURCE)
$(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
# Apply any files named gcc-*.patch from the source directory to gcc
$(SOURCE_DIR)/patch-kernel.sh $(GCC_DIR) $(SOURCE_DIR) gcc-*.patch
-if
neq ("$(strip $(TARGET_SOFT_FLOAT))",""
)
+if
eq ($(SOFT_FLOAT),true
)
ifeq ("$(strip $(ARCH))","i386")
$(SOURCE_DIR)/patch-kernel.sh $(GCC_DIR) $(SOURCE_DIR) i386-gcc-soft-float.patch
endif