Fix the condition for applying the i386 soft float patch.
authorManuel Novoa III <mjn3@codepoet.org>
Mon, 24 Nov 2003 20:50:12 +0000 (20:50 -0000)
committerManuel Novoa III <mjn3@codepoet.org>
Mon, 24 Nov 2003 20:50:12 +0000 (20:50 -0000)
make/gcc-3.3.mk

index a129bd875d44fd945473b0ba3c3e5d2560280ba3..0a12d043c8764547c27982b93641573e7e1ccd86 100644 (file)
@@ -67,7 +67,7 @@ $(GCC_DIR)/.unpacked: $(DL_DIR)/$(GCC_SOURCE)
 $(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
        # Apply any files named gcc-*.patch from the source directory to gcc
        $(SOURCE_DIR)/patch-kernel.sh $(GCC_DIR) $(SOURCE_DIR) gcc-*.patch
-ifneq ("$(strip $(TARGET_SOFT_FLOAT))","")
+ifeq ($(SOFT_FLOAT),true)
 ifeq ("$(strip $(ARCH))","i386")
        $(SOURCE_DIR)/patch-kernel.sh $(GCC_DIR) $(SOURCE_DIR) i386-gcc-soft-float.patch
 endif