gcc: apply PowerPC patch when needed
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 5 Jul 2013 08:40:52 +0000 (10:40 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 5 Jul 2013 13:30:41 +0000 (15:30 +0200)
When converting gcc to the package infrastructure, a specific thing
for PowerPC was forgotten: applying the conditional patch
powerpc-link-with-math-lib.patch.conditional. This breaks the build of
some PowerPC toolchains, with failures such as:

<http://jenkins.free-electrons.com/job/buildroot/./config=qemu_ppc_virtex_ml507_defconfig/ws/output/host/usr/lib/gcc/powerpc-buildroot-linux-uclibc/4.7.3/../../../../powerpc-buildroot-linux-uclibc/lib/libgcc_s.so.1>: undefined reference to `copysignl'

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Tested-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gcc/gcc.mk

index 790762da725a5e815797b0a48d10fdb0fc2568bc..968354b4180be06705be1ac872549281a9230535 100644 (file)
@@ -38,8 +38,17 @@ endef
 # Apply patches
 #
 
+ifeq ($(ARCH)-$(BR2_GCC_SHARED_LIBGCC),powerpc-y)
+ifneq ($(BR2_SOFT_FLOAT),)
+define HOST_GCC_APPLY_POWERPC_PATCH
+       support/scripts/apply-patches.sh $(@D) package/gcc/$(GCC_VERSION) powerpc-link-with-math-lib.patch.conditional
+endef
+endif
+endif
+
 define HOST_GCC_APPLY_PATCHES
        support/scripts/apply-patches.sh $(@D) package/gcc/$(GCC_VERSION) \*.patch
+       $(HOST_GCC_APPLY_POWERPC_PATCH)
 endef
 
 #