projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3c9c983
)
toolchain: also use arch/tune/abi options when softfloat is enabled
author
Peter Korsgaard
<jacmet@sunsite.dk>
Fri, 6 Jun 2008 12:49:53 +0000
(12:49 -0000)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Fri, 6 Jun 2008 12:49:53 +0000
(12:49 -0000)
The ifeq/endif nesting was wrong, so arch/tune/abi options where only set in
the non-softfloat case.
toolchain/gcc/Makefile.in
patch
|
blob
|
history
diff --git
a/toolchain/gcc/Makefile.in
b/toolchain/gcc/Makefile.in
index 1ada6dfaedf7ec12e89a96a0603fb246a723ae8d..b323f326e65c7e513931da40fa01e5508db0a8ac 100644
(file)
--- a/
toolchain/gcc/Makefile.in
+++ b/
toolchain/gcc/Makefile.in
@@
-50,6
+50,8
@@
else # no softfloat support
SOFT_FLOAT_CONFIG_OPTION:=
TARGET_SOFT_FLOAT:=
ARCH_FPU_SUFFIX:=
+endif
+
# some additional defaults
ifneq ($(strip $(subst ",,$(BR2_GCC_TARGET_ARCH))),)
# ")))
@@
-63,7
+65,6
@@
ifneq ($(strip $(subst ",,$(BR2_GCC_TARGET_ABI))),)
# ")))
GCC_WITH_ABI:=--with-abi=$(BR2_GCC_TARGET_ABI)
endif
-endif
# AVR32 GCC configuration
ifeq ($(strip $(BR2_avr32)),y)