- fix crosscompiler prerequisites
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 9 Feb 2007 13:05:43 +0000 (13:05 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 9 Feb 2007 13:05:43 +0000 (13:05 -0000)
toolchain/binutils/binutils.mk
toolchain/gcc/gcc-uclibc-3.x.mk

index e75e4c9db6ed6f57dee8c808e248b53cc8ee0fdb..73e70180d7f8d833974aefdf5520a19be20cae66 100644 (file)
@@ -40,8 +40,15 @@ endif
 # We do not rely on the host's gmp/mpfr but use a known working one
 BINUTILS_HOST_PREREQ:=
 BINUTILS_TARGET_PREREQ:=
-ifndef BINUTILS_NO_MPFR
 
+ifeq ($(findstring 3.,$(GCC_VERSION)),3.)
+BINUTILS_NO_MPFR:=y
+endif
+ifeq ($(findstring 4.0,$(GCC_VERSION)),4.0)
+BINUTILS_NO_MPFR:=y
+endif
+
+ifndef BINUTILS_NO_MPFR
 BINUTILS_HOST_PREREQ:=$(TOOL_BUILD_DIR)/gmp/lib/libgmp.so \
        $(TOOL_BUILD_DIR)/mpfr/lib/libmpfr.so
 
index 45e4181f0373cb23cb076dd9433141801db63623..17832148f808c851d80414a4004b066b16666103 100644 (file)
@@ -72,7 +72,7 @@ endif
 GCC_TARGET_PREREQ =
 GCC_STAGING_PREREQ= $(STAGING_DIR)/lib/libc.a
 
-ifndef $(GCC_NO_MPFR)
+ifndef GCC_NO_MPFR
 GCC_WITH_HOST_GMP=--with-gmp=$(GMP_HOST_DIR)
 GCC_WITH_HOST_MPFR=--with-mpfr=$(MPFR_HOST_DIR)