powertop: only link against -lintl when needed
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Mar 2015 08:39:22 +0000 (09:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Mar 2015 08:39:22 +0000 (09:39 +0100)
BR2_PACKAGE_GETTEXT=y might be enabled even if BR2_NEEDS_GETTEXT is
not set, and in this case, we should not link against libintl, because
it may not exist, for example with glibc toolchains.

Fixes:

  http://autobuild.buildroot.net/results/270/270018e2c9e3845a4015faa155325eea2cabe3d9/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/powertop/powertop.mk

index 43d70a30ada53e1fbcbb07b0199c18421295c324..b253a5668ac538a046febaf7a5c9ae7afc974235 100644 (file)
@@ -12,7 +12,7 @@ POWERTOP_LICENSE_FILES = COPYING
 # We're patching Makefile.am
 POWERTOP_AUTORECONF = YES
 
-ifeq ($(BR2_PACKAGE_GETTEXT),y)
+ifeq ($(BR2_NEEDS_GETTEXT),y)
 POWERTOP_DEPENDENCIES += gettext
 POWERTOP_CONF_ENV += LIBS='-lintl'
 endif