aer-inject: new package
authorTiago Brusamarello <tiago.brusamarello@datacom.ind.br>
Wed, 30 Mar 2016 13:01:52 +0000 (10:01 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Mar 2016 16:24:08 +0000 (18:24 +0200)
aer-inject allows to inject PCIE AER errors on the software level into
a running Linux kernel. This is intended for validation of the PCIE
driver error recovery handler and PCIE AER core handler.

Signed-off-by: Tiago Brusamarello <tiago.brusamarello@datacom.ind.br>
[Thomas:
 - tweak commit log
 - rewrap Config.in help text
 - remove useless AER_INJECT_MAKE_OPTS variable, use
   TARGET_CONFIGURE_OPTS directly
 - add missing newline at end of .mk file.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/aer-inject/Config.in [new file with mode: 0644]
package/aer-inject/aer-inject.mk [new file with mode: 0644]

index 8208da87d780d880cb2337214362157031c7fc37..bd76669fb81ada511c20333b3069832cb033f58d 100644 (file)
@@ -340,6 +340,7 @@ menu "Firmware"
 endmenu
        source "package/a10disp/Config.in"
        source "package/acpid/Config.in"
+       source "package/aer-inject/Config.in"
        source "package/am335x-pru-package/Config.in"
        source "package/avrdude/Config.in"
        source "package/bcache-tools/Config.in"
diff --git a/package/aer-inject/Config.in b/package/aer-inject/Config.in
new file mode 100644 (file)
index 0000000..7c737d4
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_AER_INJECT
+       bool "aer-inject"
+       help
+         aer-inject allows to inject PCIE AER errors on the software
+         level into a running Linux kernel. This is intended for
+         validation of the PCIE driver error recovery handler and
+         PCIE AER core handler.
+
+         Requires a new Linux kernel with PCIE AER error injection
+         patches.
+
+         https://git.kernel.org/cgit/linux/kernel/git/gong.chen/aer-inject.git/
diff --git a/package/aer-inject/aer-inject.mk b/package/aer-inject/aer-inject.mk
new file mode 100644 (file)
index 0000000..69189b1
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# aer-inject
+#
+################################################################################
+
+AER_INJECT_VERSION = 9bd5e2c7886fca72f139cd8402488a2235957d41
+AER_INJECT_SITE = git://git.kernel.org/pub/scm/linux/kernel/git/gong.chen/aer-inject.git
+AER_INJECT_SITE_METHOD = git
+AER_INJECT_LICENSE = GPLv2
+AER_INJECT_LICENSE_FILES = README
+AER_INJECT_DEPENDENCIES = host-flex host-bison
+
+define AER_INJECT_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+endef
+
+define AER_INJECT_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
+               DESTDIR=$(TARGET_DIR) PREFIX=/usr/bin install
+endef
+
+$(eval $(generic-package))