package/gflags: force Release mode
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 25 Apr 2020 16:22:44 +0000 (18:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 25 Apr 2020 19:28:53 +0000 (21:28 +0200)
Force Release otherwise libraries will be suffixed by _debug which will raise
unexpected build failures with packages that use gflags (e.g. rocksdb)

Fixes:
 - http://autobuild.buildroot.org/results/3545774258babc3584f69e7d523efdf7fff1acb5

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gflags/gflags.mk

index c4fce45b3e1f15f815eeec4bae92bade03d6d2a7..f32869f70d26219fc36c3ee4aa026d7f5f745e12 100644 (file)
@@ -10,8 +10,12 @@ GFLAGS_INSTALL_STAGING = YES
 GFLAGS_LICENSE = BSD-3-Clause
 GFLAGS_LICENSE_FILES = COPYING.txt
 
+# Force Release otherwise libraries will be suffixed by _debug which will raise
+# unexpected build failures with packages that use gflags (e.g. rocksdb)
+GFLAGS_CONF_OPTS = -DCMAKE_BUILD_TYPE=Release
+
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
-GFLAGS_CONF_OPTS = -DBUILD_gflags_LIB=OFF \
+GFLAGS_CONF_OPTS += -DBUILD_gflags_LIB=OFF \
        -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) -DNO_THREADS"
 endif