Makefile: target-generatelocales: add toolchain dependency
authorFabio Porcedda <fabio.porcedda@gmail.com>
Fri, 18 Apr 2014 13:07:32 +0000 (15:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Apr 2014 15:41:09 +0000 (17:41 +0200)
The target depends on the toolchain so add it as a dependency.
This also fix the support to top-level parallel make.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index c33368a9ce296d19b30ac3d83f0eb7535bd4d18f..d10da9d395e7823ff8920bfacb94e27da920bce1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -598,7 +598,7 @@ ifneq ($(GENERATE_LOCALE),)
 # data comes preferably from the toolchain, or if the toolchain does
 # not have them (Linaro toolchains), we use the ones available on the
 # host machine.
-target-generatelocales: host-localedef
+target-generatelocales: host-localedef toolchain
        $(Q)mkdir -p $(TARGET_DIR)/usr/lib/locale/
        $(Q)for locale in $(GENERATE_LOCALE) ; do \
                inputfile=`echo $${locale} | cut -f1 -d'.'` ; \