package/postgresql: add full build option
authorMaxim Kochetkov <fido_max@inbox.ru>
Mon, 25 Jan 2021 11:36:13 +0000 (14:36 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 25 Jan 2021 21:00:59 +0000 (22:00 +0100)
Postgresql includes some extra additional loadable modules.
We need just to pass "world/install-world" as make/install targets
to build this modules.

As a side effect documentation will also be built by "make world".

Signed-off-by: Maxim Kochetkov <fido_max@inbox.ru>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/postgresql/Config.in
package/postgresql/postgresql.mk

index 2f677daf5b56984664d766a862359ae09d639977..2debdc24d7c7029a4996b83ee45e149def8f43fa 100644 (file)
@@ -19,6 +19,15 @@ config BR2_PACKAGE_POSTGRESQL
 
          http://www.postgresql.org
 
+if BR2_PACKAGE_POSTGRESQL
+
+config BR2_PACKAGE_POSTGRESQL_FULL
+       bool "postgresql-full"
+       help
+         Build PostgreSQL, contrib, and documentation.
+
+endif
+
 comment "postgresql needs a toolchain w/ dynamic library, wchar"
        depends on BR2_USE_MMU
        depends on BR2_STATIC_LIBS || !BR2_USE_WCHAR
index 6c0726e88b8551f2dcec236df82b5c8cad2decdc..76d1202de097dee1566fd0ef119bae8c4da9cb80 100644 (file)
@@ -23,6 +23,12 @@ POSTGRESQL_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
 # manually, you must unset MAKELEVEL or set it to zero"
 POSTGRESQL_MAKE_OPTS = MAKELEVEL=0
 
+ifeq ($(BR2_PACKAGE_POSTGRESQL_FULL),y)
+POSTGRESQL_MAKE_OPTS += world
+POSTGRESQL_INSTALL_TARGET_OPTS += DESTDIR=$(TARGET_DIR) install-world
+POSTGRESQL_INSTALL_STAGING_OPTS += DESTDIR=$(STAGING_DIR) install-world
+endif
+
 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
 # PostgreSQL does not build against uClibc with locales
 # enabled, due to an uClibc bug, see