domoticz: do not use static version of openssl
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 30 Aug 2018 16:38:26 +0000 (18:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 1 Sep 2018 12:48:54 +0000 (14:48 +0200)
Due to the dependency on mosquitto, domoticz depends on !BR2_STATIC_LIBS
so set USE_OPENSSL_STATIC to OFF (default value is ON)

This parameter has been added in release 4.9700.

Fixes:
 - http://autobuild.buildroot.net/results/b1b84b8c12d31b9242b5732fcdd1eb76b1217366

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/domoticz/domoticz.mk

index 3d6cae4746c123248ee26b23a1e1d64e00c482f5..7f094d0976124ed939bb4df87c4faee3fbf28fa6 100644 (file)
@@ -19,8 +19,10 @@ DOMOTICZ_DEPENDENCIES = \
        zlib
 
 # Due to the dependency on mosquitto, domoticz depends on
-# !BR2_STATIC_LIBS so set USE_STATIC_BOOST to OFF
-DOMOTICZ_CONF_OPTS += -DUSE_STATIC_BOOST=OFF
+# !BR2_STATIC_LIBS so set USE_STATIC_BOOST and USE_OPENSSL_STATIC to OFF
+DOMOTICZ_CONF_OPTS += \
+       -DUSE_STATIC_BOOST=OFF \
+       -DUSE_OPENSSL_STATIC=OFF
 
 # Do not use any built-in libraries which are enabled by default for
 # lua, sqlite and mqtt